package: uboot-envtools: add nbg6716 to appropriate group
[openwrt/staging/luka.git] / target / linux / ar71xx / patches-3.14 / 719-MIPS-ath79-add-ESR900-support.patch
index a3c0f8f67ec230ed7518d94f946a133b23b45cc9..9ba3337ff8f2767bd089263a8594aee8c9d5d80f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -47,6 +47,7 @@ enum ath79_mach_type {
+@@ -48,6 +48,7 @@ enum ath79_mach_type {
        ATH79_MACH_DIR_825_C1,          /* D-Link DIR-825 rev. C1 */
        ATH79_MACH_DIR_835_A1,          /* D-Link DIR-835 rev. A1 */
        ATH79_MACH_DRAGINO2,            /* Dragino Version 2 */
@@ -20,7 +20,7 @@
 +      select ATH79_DEV_ETH
 +      select ATH79_DEV_GPIO_BUTTONS
 +      select ATH79_DEV_LEDS_GPIO
-+      select ATH79_DEV_SPI
++      select ATH79_DEV_M25P80
 +      select ATH79_DEV_USB
 +      select ATH79_DEV_WMAC
 +
@@ -29,7 +29,7 @@
        select SOC_AR933X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -60,6 +60,7 @@ obj-$(CONFIG_ATH79_MACH_DIR_615_C1)  += m
+@@ -61,6 +61,7 @@ obj-$(CONFIG_ATH79_MACH_DIR_615_C1)  += m
  obj-$(CONFIG_ATH79_MACH_DIR_825_B1)   += mach-dir-825-b1.o
  obj-$(CONFIG_ATH79_MACH_DIR_825_C1)   += mach-dir-825-c1.o
  obj-$(CONFIG_ATH79_MACH_DRAGINO2)     += mach-dragino2.o