kernel: update linux 3.3 to 3.3.4
[openwrt/staging/jow.git] / target / linux / at91 / Makefile
index d37aa5378373161b8ea8c65cfc79814032b1f570..01d942a8ed0f9ae458312997bf00da5bc7c9eb7c 100644 (file)
@@ -8,19 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
+FEATURES:=squashfs jffs2 targz ext2 usb
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+SUBTARGETS:=9g20 9260 9263
 
-LINUX_VERSION:=2.6.34.1
+LINUX_VERSION:=3.3.4
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES+= kmod-usb-ohci
 KERNELNAME:="uImage"
 
-define Target/Description
-       Build firmware images for Acmesystems NetusG20 board
-endef
-
 $(eval $(call BuildTarget))