at91bootstrap: add sama5d27_som1_eksd1_uboot as default defconfig
[openwrt/staging/wigyori.git] / target / linux / at91 / image / Makefile
index 49d93aa97d7faae48cdaa944e58e3c90869a9483..3a906a6ca8516b2432ad6921292cd5a8e66de3dd 100644 (file)
@@ -13,17 +13,11 @@ define Build/at91-install-zImage
     $(CP) $(KDIR)/zImage $@
 endef
 
-ifeq ($(SUBTARGET),legacy)
-include ./legacy.mk
+ifeq ($(SUBTARGET),sam9x)
+include ./sam9x.mk
 endif
-ifeq ($(SUBTARGET),sama5d2)
-include ./sama5d2.mk
-endif
-ifeq ($(SUBTARGET),sama5d3)
-include ./sama5d3.mk
-endif
-ifeq ($(SUBTARGET),sama5d4)
-include ./sama5d4.mk
+ifeq ($(SUBTARGET),sama5)
+include ./sama5.mk
 endif
 
 AT91_SD_BOOT_PARTSIZE:=64
@@ -61,9 +55,13 @@ define Build/at91-sdcard
     $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
     ::u-boot.bin
 
-  mcopy -i $@.boot \
-    $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
-    ::BOOT.bin
+  $(if $(findstring at91-sama5d27_som1_ek,$@), \
+      mcopy -i $@.boot \
+          $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd1_uboot/at91bootstrap.bin \
+          ::BOOT.bin,
+      mcopy -i $@.boot \
+          $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot/at91bootstrap.bin \
+          ::BOOT.bin)
 
   ./gen_at91_sdcard_img.sh \
       $@.img \