at91: remove Build/at91-sdcard command
[openwrt/staging/jow.git] / target / linux / at91 / image / Makefile
index 99c7e21669e1150006a934b9dd90f6017e561646..3b01d421310b6c2c90073dcc46962098b8d1c148 100644 (file)
@@ -9,33 +9,42 @@ include $(INCLUDE_DIR)/image.mk
 
 KERNEL_LOADADDR := 0x20008000
 
-ifeq ($(SUBTARGET),legacy)
-include ./legacy.mk
-UBIFS_OPTS := -m 2048 -e 126KiB -c 2048
-endif
+define Build/at91-install-zImage
+    $(CP) $(KDIR)/zImage $@
+endef
 
+ifeq ($(SUBTARGET),sam9x)
+include ./sam9x.mk
+endif
 ifeq ($(SUBTARGET),sama5)
 include ./sama5.mk
-UBIFS_OPTS := -m 2048 -e 124KiB -c 2048
 endif
 
+AT91_SD_BOOT_PARTSIZE:=64
+FAT32_BLOCK_SIZE:=1024
+FAT32_BLOCKS:=$(shell echo \
+  $$(($(AT91_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+
 define Device/Default
+  $(Device/default-nand)
   PROFILES := Default
-  FILESYSTEMS := squashfs ubifs
+  FILESYSTEMS := squashfs ubifs ext4
   DEVICE_DTS := $(1)
   KERNEL_NAME := zImage
   KERNEL_SIZE := 4096k
   KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
-  BLOCKSIZE := 128k
-  PAGESIZE := 2048
-  SUBPAGESIZE := 512
-  DTB_SIZE :=
+  DTB_SIZE := 128k
 endef
 
 define Device/dtb
   KERNEL := kernel-bin | lzma | uImage lzma
 endef
 
+define Device/evaluation-sdimage
+  IMAGES += sdcard.img.gz
+  IMAGE/sdcard.img.gz := at91-sdcard
+endef
+
 define Device/evaluation
   KERNEL_INSTALL := 1
   KERNEL_SUFFIX := -uImage
@@ -45,7 +54,7 @@ endef
 
 define Device/evaluation-zImage
   IMAGES += zImage
-  IMAGE/zImage := install-zImage
+  IMAGE/zImage := at91-install-zImage
 endef
 
 define Device/evaluation-dtb
@@ -56,6 +65,12 @@ define Device/evaluation-dtb
   IMAGE/dtb := install-dtb
 endef
 
+define Device/evaluation-fit
+  $(Device/evaluation)
+  KERNEL_SUFFIX := -fit-uImage.itb
+  KERNEL := kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+endef
+
 define Device/production
   UBINIZE_OPTS := -E 5
   IMAGES := factory.bin
@@ -65,7 +80,6 @@ endef
 define Device/production-dtb
   $(Device/production)
   $(Device/dtb)
-  DTB_SIZE := 128k
   IMAGE/factory.bin := append-dtb | pad-to $$$$(DTB_SIZE) \
          | append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
 endef