replace old quote stripping with calls to qstrip macro
[openwrt/staging/yousong.git] / target / linux / at91 / image / u-boot / Makefile
index f53df11a908dc91924ef3c8d3745b4d8ce80094f..89a2be0494c230d5e5557074d6fabb5a55b82382 100644 (file)
@@ -20,9 +20,9 @@ PKG_CAT:=bzcat
 
 include $(INCLUDE_DIR)/package.mk
 
-UBOOT_CONFIG=$(strip $(subst ",, $(CONFIG_UBOOT_TARGET)))
-LAN_IP=$(strip $(CONFIG_UBOOT_IPADDR))
-LAN_SERVERIP=$(strip $(subst ",, $(CONFIG_UBOOT_SERVERIP)))
+UBOOT_CONFIG=$(call qstrip,$(CONFIG_UBOOT_TARGET))
+LAN_IP=$(call qstrip,$(CONFIG_UBOOT_IPADDR))
+LAN_SERVERIP=$(call qstrip,$(CONFIG_UBOOT_SERVERIP))
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config