build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt/svn-archive/archive.git] / target / linux / at91-2.6 / image / Makefile
index 8b1a9476d796dd08898d6247f69e76383c02e774..7e855f06ef2f609188de771373314660820450d5 100644 (file)
@@ -9,21 +9,24 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Build/Clean
-       $(MAKE) -C romboot clean
+       $(MAKE) -C dfboot clean
        $(MAKE) -C u-boot clean
 endef
 
 define Build/Compile
-       $(MAKE) -C romboot compile
-#      $(MAKE) -C u-boot configure
+       $(MAKE) -C dfboot compile
        $(MAKE) -C u-boot compile
+       $(KDIR)/u-boot-1.1.4/tools/ubparams
+       cp params $(KDIR)
 endef
 
 define Image/Prepare
   cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
-       cp $(KDIR)/romboot/romboot.bin $(KDIR)/romboot.bin
+       cp $(KDIR)/dfboot/dfboot.bin $(KDIR)/dfboot.bin
+       cp $(KDIR)/dfboot/dfbptest.bin $(KDIR)/dfbptest.bin
        cp $(KDIR)/u-boot-1.1.4/u-boot.bin $(KDIR)/u-boot.bin
-       cat $(KDIR)/romboot/romboot.block $(KDIR)/u-boot-1.1.4/u-boot.block > $(KDIR)/loaders.block
+       dd if=$(KDIR)/u-boot.bin of=$(KDIR)/u-boot.block bs=100k count=1 conv=sync
+       cat $(KDIR)/u-boot.block $(KDIR)/params > $(KDIR)/u-boot.full
 endef
 
 define Image/BuildKernel
@@ -31,6 +34,11 @@ define Image/BuildKernel
 endef
 
 define Image/Build
+       dd if=$(KDIR)/uImage of=$(KDIR)/uImage.block bs=8448 conv=sync
+       dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.block bs=8448 conv=sync
+       cat $(KDIR)/uImage.block $(KDIR)/root.block > $(KDIR)/knlroot.bin
+       $(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/dfboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
+       cp $(KDIR)/dfbptest.bin $(BIN_DIR)
        $(call Image/Build/$(1),$(1))
 endef