build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt/svn-archive/archive.git] / target / linux / at91-2.6 / image / Makefile
index b498059a57cdc2a4b2d5911c372cd8090e656a0b..7e855f06ef2f609188de771373314660820450d5 100644 (file)
@@ -9,13 +9,11 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Build/Clean
-#      $(MAKE) -C romboot clean
        $(MAKE) -C dfboot clean
        $(MAKE) -C u-boot clean
 endef
 
 define Build/Compile
-#      $(MAKE) -C romboot compile
        $(MAKE) -C dfboot compile
        $(MAKE) -C u-boot compile
        $(KDIR)/u-boot-1.1.4/tools/ubparams
@@ -39,7 +37,7 @@ define Image/Build
        dd if=$(KDIR)/uImage of=$(KDIR)/uImage.block bs=8448 conv=sync
        dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.block bs=8448 conv=sync
        cat $(KDIR)/uImage.block $(KDIR)/root.block > $(KDIR)/knlroot.bin
-       $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/dfboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
+       $(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/dfboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
        cp $(KDIR)/dfbptest.bin $(BIN_DIR)
        $(call Image/Build/$(1),$(1))
 endef