ath79: add support for TP-Link CPE510 v1
[openwrt/staging/stintel.git] / target / linux / ath79 / image / generic-tp-link.mk
index a5844227e4378a5fb1c572ddeecd2529e9a902c4..ffbdfbc14f89c9c14106f30f84b3ec0d7d0e761f 100644 (file)
@@ -195,6 +195,18 @@ define Device/tplink_cpe210-v3
 endef
 TARGET_DEVICES += tplink_cpe210-v3
 
+define Device/tplink_cpe510-v1
+  $(Device/tplink-loader-okli)
+  ATH_SOC := ar9344
+  IMAGE_SIZE := 7680k
+  DEVICE_MODEL := CPE510
+  DEVICE_VARIANT := v1
+  DEVICE_PACKAGES := rssileds
+  TPLINK_BOARD_ID := CPE510
+  SUPPORTED_DEVICES += cpe510
+endef
+TARGET_DEVICES += tplink_cpe510-v1
+
 define Device/tplink_cpe510-v2
   $(Device/tplink-loader-okli)
   ATH_SOC := ar9344