ath79: add support for ASUS RP-AC66
[openwrt/staging/chunkeey.git] / target / linux / ath79 / image / generic.mk
index ff2476474060e7b01044e522fcaa70159d79559c..5e211a33a4d87651a92af879992a1edda8451366 100644 (file)
@@ -330,6 +330,18 @@ define Device/aruba_ap-105
 endef
 TARGET_DEVICES += aruba_ap-105
 
+define Device/asus_rp-ac66
+  SOC := qca9563
+  DEVICE_VENDOR := ASUS
+  DEVICE_MODEL := RP-AC66
+  IMAGES += factory.bin
+  IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+       append-rootfs | pad-rootfs
+  DEVICE_PACKAGES := kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct \
+       rssileds -swconfig
+endef
+TARGET_DEVICES += asus_rp-ac66
+
 define Device/atheros_db120
   $(Device/loader-okli-uimage)
   SOC := ar9344