ath79: add support for ALFA Network R36A
[openwrt/staging/thess.git] / target / linux / ath79 / image / generic.mk
index ce927ecd4f2c3be4358fa8ccd1e4e126a16df75f..605f66f77fcad3d9ee828ac60ef6d8e29873539a 100644 (file)
@@ -237,6 +237,16 @@ define Device/alfa-network_ap121fe
 endef
 TARGET_DEVICES += alfa-network_ap121fe
 
+define Device/alfa-network_r36a
+  SOC := qca9531
+  DEVICE_VENDOR := ALFA Network
+  DEVICE_MODEL := R36A
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
+  IMAGE_SIZE := 15872k
+  SUPPORTED_DEVICES += r36a
+endef
+TARGET_DEVICES += alfa-network_r36a
+
 define Device/allnet_all-wap02860ac
   SOC := qca9558
   DEVICE_VENDOR := ALLNET