ath79: add support for ZyXEL NWA1123-AC
[openwrt/staging/hauke.git] / target / linux / ath79 / image / generic.mk
index 617f1eed3047519b56eb5203c8bdd0464be30640..612b79f8d65881bcc32aabe061cc433a839241cf 100644 (file)
@@ -2716,6 +2716,16 @@ define Device/zyxel_nwa1121-ni
 endef
 TARGET_DEVICES += zyxel_nwa1121-ni
 
+define Device/zyxel_nwa1123-ac
+  $(Device/zyxel_nwa11xx)
+  DEVICE_MODEL := NWA1123
+  DEVICE_VARIANT := AC
+  ZYXEL_MODEL_STRING := AAOX
+  DEVICE_PACKAGES := kmod-ath10k-ct-smallbuffers \
+       ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += zyxel_nwa1123-ac
+
 define Device/zyxel_nwa1123-ni
   $(Device/zyxel_nwa11xx)
   DEVICE_MODEL := NWA1123