ath79: add support for OpenMesh OM2P-HS v3
[openwrt/staging/hauke.git] / target / linux / ath79 / image / generic.mk
index 1454c14e44aa86382fb17ad9f7734fae70406cfb..631cc2fd6a54b2366edf13ddb89866cc993cf00f 100644 (file)
@@ -1586,6 +1586,24 @@ define Device/openmesh_om2p-hs-v1
 endef
 TARGET_DEVICES += openmesh_om2p-hs-v1
 
+define Device/openmesh_om2p-hs-v2
+  $(Device/openmesh_om2p-common)
+  SOC := ar9341
+  DEVICE_MODEL := OM2P-HS
+  DEVICE_VARIANT := v2
+  SUPPORTED_DEVICES += om2p-hsv2
+endef
+TARGET_DEVICES += openmesh_om2p-hs-v2
+
+define Device/openmesh_om2p-hs-v3
+  $(Device/openmesh_om2p-common)
+  SOC := ar9341
+  DEVICE_MODEL := OM2P-HS
+  DEVICE_VARIANT := v3
+  SUPPORTED_DEVICES += om2p-hsv3
+endef
+TARGET_DEVICES += openmesh_om2p-hs-v3
+
 define Device/openmesh_om2p-hs-v4
   $(Device/openmesh_om2p-common)
   SOC := qca9533