ath79: add support for Buffalo WZR-HP-AG300H
[openwrt/staging/dedeckeh.git] / target / linux / ath79 / image / tiny.mk
index 0047554620eefa6317d08d85c1c90a6829c5b4ba..531a7f30c2eb85c476de095074b66657a9b6f7ee 100644 (file)
@@ -1,23 +1,6 @@
-DEVICE_VARS += ROOTFS_SIZE
-
-define Build/buffalo-tftp-header
-       ( \
-               echo -n -e "# Airstation Public Fmt1" | dd bs=32 count=1 conv=sync; \
-               dd if=$@; \
-       ) > $@.new
-  mv $@.new $@
-endef
+include ./common-buffalo.mk
 
-define Build/buffalo-tag
-       $(eval product=$(word 1,$(1)))
-       $(STAGING_DIR_HOST)/bin/buffalo-tag \
-               -c 0x80041000 -d 0x801e8000 -w 3 \
-               -a ath -v 1.99 -m 1.01 -f 1 \
-               -b $(product) -p $(product) \
-               -r M_ -l mlang8 \
-               -i $@ -o $@.new
-       mv $@.new $@
-endef
+DEVICE_VARS += ROOTFS_SIZE
 
 define Device/buffalo_bhr-4grv2
   ATH_SOC := qca9558