kernel: bump 4.14 to 4.14.41
[openwrt/staging/blogic.git] / target / linux / ath79 / patches-4.14 / 0003-leds-add-reset-controller-based-driver.patch
index 358da3b8302ce25644767aa2b6c71520f99b4db8..495d79288b3b7afb63cefd1c167ed1a58c46fbe4 100644 (file)
@@ -11,10 +11,8 @@ Signed-off-by: John Crispin <john@phrozen.org>
  3 files changed, 149 insertions(+)
  create mode 100644 drivers/leds/leds-reset.c
 
-Index: linux-4.14.32/drivers/leds/Kconfig
-===================================================================
---- linux-4.14.32.orig/drivers/leds/Kconfig
-+++ linux-4.14.32/drivers/leds/Kconfig
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
 @@ -696,6 +696,17 @@ config LEDS_NIC78BX
          To compile this driver as a module, choose M here: the module
          will be called leds-nic78bx.
@@ -33,10 +31,8 @@ Index: linux-4.14.32/drivers/leds/Kconfig
  comment "LED Triggers"
  source "drivers/leds/trigger/Kconfig"
  
-Index: linux-4.14.32/drivers/leds/leds-reset.c
-===================================================================
 --- /dev/null
-+++ linux-4.14.32/drivers/leds/leds-reset.c
++++ b/drivers/leds/leds-reset.c
 @@ -0,0 +1,137 @@
 +/*
 + * Copyright (C) 2018 John Crispin <john@phrozen.org>
@@ -175,10 +171,8 @@ Index: linux-4.14.32/drivers/leds/leds-reset.c
 +MODULE_DESCRIPTION("reset controller LED driver");
 +MODULE_LICENSE("GPL");
 +MODULE_ALIAS("platform:leds-reset");
-Index: linux-4.14.32/drivers/leds/Makefile
-===================================================================
---- linux-4.14.32.orig/drivers/leds/Makefile
-+++ linux-4.14.32/drivers/leds/Makefile
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
 @@ -73,6 +73,7 @@ obj-$(CONFIG_LEDS_PM8058)            += leds-pm805
  obj-$(CONFIG_LEDS_MLXCPLD)            += leds-mlxcpld.o
  obj-$(CONFIG_LEDS_NIC78BX)            += leds-nic78bx.o