kernel: bump 6.1 to 6.1.75
[openwrt/staging/svanheule.git] / target / linux / ath79 / patches-6.1 / 800-leds-add-reset-controller-based-driver.patch
index 7122756c526687e46d9565fbb0e16fe06f319cef..0002b9b95b002f6ac0c1a6ccd12d02f237617eab 100644 (file)
@@ -13,9 +13,9 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -876,6 +876,17 @@ source "drivers/leds/blink/Kconfig"
- comment "Flash and Torch LED drivers"
- source "drivers/leds/flash/Kconfig"
+@@ -874,6 +874,17 @@ source "drivers/leds/flash/Kconfig"
+ comment "RGB LED drivers"
+ source "drivers/leds/rgb/Kconfig"
  
 +config LEDS_RESET
 +      tristate "LED support for reset-controller API"
@@ -176,7 +176,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +MODULE_ALIAS("platform:leds-reset");
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -87,6 +87,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA)              += leds
+@@ -86,6 +86,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA)              += leds
  obj-$(CONFIG_LEDS_WM831X_STATUS)      += leds-wm831x-status.o
  obj-$(CONFIG_LEDS_WM8350)             += leds-wm8350.o
  obj-$(CONFIG_LEDS_WRAP)                       += leds-wrap.o