ramips: ramips_esw: move hardware initialization into a separate function
[openwrt/svn-archive/archive.git] / target / linux / atheros / patches-2.6.33 / 100-board.patch
index 014ea44f23e2327e078cb4eb16a944d65b7e448c..6cf6ddbfbf6c635a09e0d17d1f3f59739979f1f3 100644 (file)
@@ -30,7 +30,7 @@
  source "arch/mips/jazz/Kconfig"
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -308,6 +308,13 @@ cflags-$(CONFIG_SOC_AU1X00)       += -I$(srctr
+@@ -310,6 +310,13 @@ cflags-$(CONFIG_SOC_AU1X00)       += -I$(srctr
  
  
  #
@@ -94,7 +94,7 @@
 + * Copyright (C) 2006-2009 Felix Fietkau <nbd@openwrt.org>
 + */
 +
-+#include <linux/autoconf.h>
++#include <generated/autoconf.h>
 +#include <linux/init.h>
 +#include <linux/module.h>
 +#include <linux/types.h>
 + */
 +
 +#include <linux/init.h>
-+#include <linux/autoconf.h>
++#include <generated/autoconf.h>
 +#include <linux/kernel.h>
 +#include <linux/string.h>
 +#include <linux/mm.h>
 +
 --- /dev/null
 +++ b/arch/mips/ar231x/ar5312.c
-@@ -0,0 +1,547 @@
+@@ -0,0 +1,549 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 + * License.  See the file "COPYING" in the main directory of this archive
 + * Platform devices for Atheros SoCs
 + */
 +
-+#include <linux/autoconf.h>
++#include <generated/autoconf.h>
 +#include <linux/init.h>
 +#include <linux/module.h>
 +#include <linux/types.h>
 +              if (!ar231x_board.radio)
 +                      return 0;
 +
-+              if (*((u32 *) radio) & AR531X_RADIO0_MASK)
++              if ((*((u32 *) radio) & AR531X_RADIO0_MASK) &&
++                  (config->flags & BD_WLAN0))
 +                      ar231x_add_wmac(0, AR531X_WLAN0,
 +                              AR5312_IRQ_WLAN0_INTRS);
 +
 +              break;
 +      }
 +
-+      if (*((u32 *) radio) & AR531X_RADIO1_MASK)
++      if ((*((u32 *) radio) & AR531X_RADIO1_MASK) &&
++          (config->flags & BD_WLAN1))
 +              ar231x_add_wmac(1, AR531X_WLAN1,
 +                      AR5312_IRQ_WLAN1_INTRS);
 +
 + * Platform devices for Atheros SoCs
 + */
 +
-+#include <linux/autoconf.h>
++#include <generated/autoconf.h>
 +#include <linux/init.h>
 +#include <linux/module.h>
 +#include <linux/types.h>