enable start-stop-daemon by default, i want to use this to clean up a few init script...
[openwrt/staging/dedeckeh.git] / target / linux / au1000-2.6 / Makefile
index 25fc776129b40c34cf88eca6bfff5de144f48108..d7b9f739ab7f6fa2b953555f53456fa21d2f0b79 100644 (file)
@@ -9,7 +9,9 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=au1000
 BOARDNAME:=AMD Alchemy AU1x00
-FEATURES:=jffs2
+FEATURES:=jffs2 usb pci
+
+LINUX_VERSION:=2.6.22.4
 
 define Target/Description
        Build firmware for AMD Alchemy 1500 boards
@@ -25,23 +27,8 @@ define Kernel/BuildImage
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
-define Profile/Atheros
-  NAME:=Atheros WiFi (default)
-  PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/Intel
-  NAME:=Intel IPW2200 WiFi
-  PACKAGES:=kmod-net-ipw2200
-endef
-$(eval $(call Profile,Intel))
-
-define Profile/Broadcom
-  NAME:=Broadcom BCM43xx WiFi
-  PACKAGES:=kmod-net-bcm43xx
-endef
-$(eval $(call Profile,Broadcom))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))