enable start-stop-daemon by default, i want to use this to clean up a few init script...
[openwrt/staging/dedeckeh.git] / target / linux / au1000-2.6 / Makefile
index 4b20032f95124e123621419933ff8ce19e6b5fd0..d7b9f739ab7f6fa2b953555f53456fa21d2f0b79 100644 (file)
@@ -9,18 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=au1000
 BOARDNAME:=AMD Alchemy AU1x00
-FEATURES:=jffs2
+FEATURES:=jffs2 usb pci
+
+LINUX_VERSION:=2.6.22.4
 
 define Target/Description
        Build firmware for AMD Alchemy 1500 boards
        (e.g. 4G-Systems Mesh/Access Cube ...)
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += yamonenv
 
 define Kernel/BuildImage
        $(call Kernel/BuildImage/Default)
@@ -28,23 +27,8 @@ define Kernel/BuildImage
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
-define Profile/Atheros
-  NAME:=Atheros WiFi (default)
-  PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/Intel
-  NAME:=Intel IPW2200 WiFi
-  PACKAGES:=kmod-net-ipw2200
-endef
-$(eval $(call Profile,Intel))
-
-define Profile/Broadcom
-  NAME:=Broadcom BCM43xx WiFi
-  PACKAGES:=kmod-net-bcm43xx
-endef
-$(eval $(call Profile,Broadcom))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))