bcm27xx: remove linux 5.10 compatibility
[openwrt/staging/chunkeey.git] / target / linux / bcm27xx / modules / hwmon.mk
index 02ac204e1a2d4b78720c3cf60cceb4f6d0701c6f..0f1547cd4f802cbf095c69863e2b4b5c22ac1514 100644 (file)
@@ -15,19 +15,3 @@ define KernelPackage/hwmon-raspberrypi/description
 endef
 
 $(eval $(call KernelPackage,hwmon-raspberrypi))
-
-
-define KernelPackage/hwmon-rpi-poe-fan
-  SUBMENU:=$(HWMON_MENU)
-  TITLE:=Raspberry Pi PoE HAT fan
-  DEPENDS:=@TARGET_bcm27xx @LINUX_5_10 +kmod-hwmon-core
-  KCONFIG:=CONFIG_SENSORS_RPI_POE_FAN
-  FILES:=$(LINUX_DIR)/drivers/hwmon/rpi-poe-fan.ko
-  AUTOLOAD:=$(call AutoProbe,rpi-poe-fan)
-endef
-
-define KernelPackage/hwmon-rpi-poe-fan/description
-  Raspberry Pi PoE HAT fan driver
-endef
-
-$(eval $(call KernelPackage,hwmon-rpi-poe-fan))