kernel: update 3.14 to 3.14.18
[openwrt/staging/stintel.git] / target / linux / bcm53xx / Makefile
index 4986d8061955a5e2ed3de12080b3f8422fdc11a6..938bbaf6e92b44e4b2696f01bb03e3bb7760946c 100644 (file)
@@ -8,11 +8,12 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=bcm53xx
-BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
+BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
 FEATURES:=squashfs usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+CPU_TYPE:=cortex-a9
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.14.18
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -20,10 +21,8 @@ define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
-CFLAGS:=-Os -pipe -mtune=cortex-a9 -march=armv7-a -mfpu=vfp -mfloat-abi=softfp
-
 KERNELNAME:="zImage dtbs"
 
-DEFAULT_PACKAGES += swconfig
+DEFAULT_PACKAGES += swconfig wpad-mini
 
 $(eval $(call BuildTarget))