bcm63xx: add support for Technicolor TG582n Telecom Italia branded
[openwrt/staging/rmilecki.git] / target / linux / bcm63xx / image / bcm63xx.mk
index c9aacd5ebd1ccef0ce9d3f4982fe4d977e0c4a9a..81cf98b44bac4c27b4ddafc3b002f782df75c6c0 100644 (file)
@@ -1098,6 +1098,20 @@ define Device/t-com_speedport-w-500v
 endef
 TARGET_DEVICES += t-com_speedport-w-500v
 
+### Technicolor ###
+define Device/technicolor_tg582n-telecom-italia
+  $(Device/bcm63xx)
+  DEVICE_VENDOR := Technicolor
+  DEVICE_MODEL := TG582n
+  DEVICE_VARIANT := Telecom Italia
+  IMAGES += sysupgrade.bin
+  CFE_BOARD_ID := DANT-V
+  CHIP_ID := 6328
+  FLASH_MB := 16
+  DEVICE_PACKAGES := $(USB2_PACKAGES) $(B43_PACKAGES)
+endef
+TARGET_DEVICES += technicolor_tg582n-telecom-italia
+
 ### Tecom ###
 define Device/tecom_gw6000
   $(Device/bcm63xx-legacy)