[adm5120] add morse LED trigger, will be used for diagnostic, update kernel config
[openwrt/svn-archive/archive.git] / target / linux / brcm-2.4 / Makefile
index 7319ccabd470b62240d6e62c643afdc983da3a35..d93e0b6b9b84a83b570584df917ced4df8834dc6 100644 (file)
@@ -7,23 +7,19 @@
 include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
-BOARD:=brcm
+BOARD:=brcm-2.4
 BOARDNAME:=Broadcom BCM947xx/953xx
-FEATURES:=pci usb pcmcia squashfs jffs2
+FEATURES:=squashfs
+
+KERNEL:=2.4
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-switch kmod-diag nvram 
 
 define Target/Description
        Build firmware images for Broadcom based routers
        (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
-
-       This one builds the generic .trx images, activate one of the
-       options below for creating device specific files for use
-       with TFTP client too.
 endef
 
-LINUX_VERSION:=2.4.32
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
-
-include $(INCLUDE_DIR)/kernel-build.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))