strip the kernel version suffix from target directories, except for brcm-2.4 (the...
[openwrt/staging/dedeckeh.git] / target / linux / brcm-2.4 / Makefile
index 7319ccabd470b62240d6e62c643afdc983da3a35..ed7336daeaca26ac004236152d909d294c3c68ea 100644 (file)
@@ -7,23 +7,21 @@
 include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
-BOARD:=brcm
+BOARD:=brcm-2.4
 BOARDNAME:=Broadcom BCM947xx/953xx
-FEATURES:=pci usb pcmcia squashfs jffs2
+FEATURES:=squashfs
 
 define Target/Description
        Build firmware images for Broadcom based routers
        (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
-
-       This one builds the generic .trx images, activate one of the
-       options below for creating device specific files for use
-       with TFTP client too.
 endef
 
-LINUX_VERSION:=2.4.32
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
+KERNEL:=2.4
 
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-switch kmod-diag nvram
+
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))