brcm2708: unbreak the spidev build
[openwrt/staging/wigyori.git] / target / linux / brcm2708 / Makefile
index 112a5b6b43d1cb298a59d95c980367f435257856..9240f664210d183b1e21abe4044e7250dbf31259 100644 (file)
@@ -11,19 +11,19 @@ ARCH:=arm
 BOARD:=brcm2708
 BOARDNAME:=Broadcom BCM27xx
 FEATURES:=ext4 audio usb usbgadget display gpio fpu
-MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 SUBTARGETS:=bcm2708 bcm2709 bcm2710
 
 KERNEL_PATCHVER:=4.4
 
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
-
 define Target/Description
        Build firmware image for Broadcom BCM27xx SoC devices.
        Currently produces SD Card image for Raspberry Pi.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
+
 KERNELNAME:=Image dtbs
 
 $(eval $(call BuildTarget))