brcm2708: update 3.10 patches with raspberrypi/rpi-3.10.y of 27 Apr. 2014
[openwrt/svn-archive/archive.git] / target / linux / brcm2708 / patches-3.10 / 0019-Backport-of-Chris-Boot-s-i2c-and-spi-drivers.patch
index f19aafb17e1bd4ed78dabc44fde2f59c0fc70f61..59cf718f14922458f39dc96b24c0bca97b3f8754 100644 (file)
@@ -1,7 +1,7 @@
-From 5a3b6667524d9164140077cfadf61b165f0950ec Mon Sep 17 00:00:00 2001
+From eb8655fe20ef40189e9cda1441d488c5a23c89f2 Mon Sep 17 00:00:00 2001
 From: popcornmix <popcornmix@gmail.com>
 Date: Wed, 3 Jul 2013 00:41:10 +0100
-Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
+Subject: [PATCH 019/196] Backport of Chris Boot's i2c and spi drivers.
 
 ---
  arch/arm/configs/bcmrpi_cutdown_defconfig     |  10 +
@@ -19,6 +19,8 @@ Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
  create mode 100644 drivers/i2c/busses/i2c-bcm2708.c
  create mode 100644 drivers/spi/spi-bcm2708.c
 
+diff --git a/arch/arm/configs/bcmrpi_cutdown_defconfig b/arch/arm/configs/bcmrpi_cutdown_defconfig
+index e519412..a61a915 100644
 --- a/arch/arm/configs/bcmrpi_cutdown_defconfig
 +++ b/arch/arm/configs/bcmrpi_cutdown_defconfig
 @@ -492,3 +492,13 @@ CONFIG_CRYPTO_DEFLATE=m
@@ -35,6 +37,8 @@ Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
 +CONFIG_SPI_MASTER=y
 +CONFIG_SPI_BCM2708=m
 +
+diff --git a/arch/arm/configs/bcmrpi_defconfig b/arch/arm/configs/bcmrpi_defconfig
+index df947e5..6219df3 100644
 --- a/arch/arm/configs/bcmrpi_defconfig
 +++ b/arch/arm/configs/bcmrpi_defconfig
 @@ -214,6 +214,11 @@ CONFIG_SERIAL_AMBA_PL011=y
@@ -49,6 +53,8 @@ Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
  CONFIG_GPIO_SYSFS=y
  # CONFIG_HWMON is not set
  CONFIG_WATCHDOG=y
+diff --git a/arch/arm/mach-bcm2708/Kconfig b/arch/arm/mach-bcm2708/Kconfig
+index 63bb76c..a35ff89 100644
 --- a/arch/arm/mach-bcm2708/Kconfig
 +++ b/arch/arm/mach-bcm2708/Kconfig
 @@ -31,4 +31,11 @@ config BCM2708_NOL2CACHE
@@ -63,6 +69,8 @@ Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
 +        help
 +          Binds spidev driver to the SPI0 master
  endmenu
+diff --git a/arch/arm/mach-bcm2708/bcm2708.c b/arch/arm/mach-bcm2708/bcm2708.c
+index 67f3608..03b8ec5 100644
 --- a/arch/arm/mach-bcm2708/bcm2708.c
 +++ b/arch/arm/mach-bcm2708/bcm2708.c
 @@ -31,6 +31,7 @@
@@ -105,7 +113,7 @@ Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
         }
  };
  
-@@ -434,6 +442,89 @@ static struct platform_device bcm2708_al
+@@ -434,6 +442,89 @@ static struct platform_device bcm2708_alsa_devices[] = {
                },
  };
  
@@ -217,6 +225,8 @@ Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
  }
  
  static void timer_set_mode(enum clock_event_mode mode,
+diff --git a/arch/arm/mach-bcm2708/include/mach/platform.h b/arch/arm/mach-bcm2708/include/mach/platform.h
+index 110ce07..4d3c15d 100644
 --- a/arch/arm/mach-bcm2708/include/mach/platform.h
 +++ b/arch/arm/mach-bcm2708/include/mach/platform.h
 @@ -63,9 +63,12 @@
@@ -232,9 +242,11 @@ Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
  #define USB_BASE                 (BCM2708_PERI_BASE + 0x980000) /* DTC_OTG USB controller */
  #define MCORE_BASE               (BCM2708_PERI_BASE + 0x0000)   /* Fake frame buffer device (actually the multicore sync block*/
  
+diff --git a/drivers/i2c/busses/Kconfig b/drivers/i2c/busses/Kconfig
+index d4fe13e..290aee4 100644
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -345,6 +345,14 @@ config I2C_BCM2835
+@@ -347,6 +347,14 @@ config I2C_BCM2835
          This support is also available as a module.  If so, the module
          will be called i2c-bcm2835.
  
@@ -249,9 +261,11 @@ Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
  config I2C_BLACKFIN_TWI
        tristate "Blackfin TWI I2C support"
        depends on BLACKFIN
+diff --git a/drivers/i2c/busses/Makefile b/drivers/i2c/busses/Makefile
+index 8f4fc23..ef26c38 100644
 --- a/drivers/i2c/busses/Makefile
 +++ b/drivers/i2c/busses/Makefile
-@@ -32,6 +32,7 @@ obj-$(CONFIG_I2C_POWERMAC)   += i2c-powerm
+@@ -32,6 +32,7 @@ obj-$(CONFIG_I2C_POWERMAC)   += i2c-powermac.o
  obj-$(CONFIG_I2C_AT91)                += i2c-at91.o
  obj-$(CONFIG_I2C_AU1550)      += i2c-au1550.o
  obj-$(CONFIG_I2C_BCM2835)     += i2c-bcm2835.o
@@ -259,6 +273,9 @@ Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
  obj-$(CONFIG_I2C_BLACKFIN_TWI)        += i2c-bfin-twi.o
  obj-$(CONFIG_I2C_CBUS_GPIO)   += i2c-cbus-gpio.o
  obj-$(CONFIG_I2C_CPM)         += i2c-cpm.o
+diff --git a/drivers/i2c/busses/i2c-bcm2708.c b/drivers/i2c/busses/i2c-bcm2708.c
+new file mode 100644
+index 0000000..7cae615
 --- /dev/null
 +++ b/drivers/i2c/busses/i2c-bcm2708.c
 @@ -0,0 +1,396 @@
@@ -658,6 +675,8 @@ Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
 +MODULE_AUTHOR("Chris Boot <bootc@bootc.net>");
 +MODULE_LICENSE("GPL v2");
 +MODULE_ALIAS("platform:" DRV_NAME);
+diff --git a/drivers/spi/Kconfig b/drivers/spi/Kconfig
+index 92a9345..f0a2a9f 100644
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
 @@ -86,6 +86,14 @@ config SPI_BCM2835
@@ -675,9 +694,11 @@ Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
  config SPI_BFIN5XX
        tristate "SPI controller driver for ADI Blackfin5xx"
        depends on BLACKFIN
+diff --git a/drivers/spi/Makefile b/drivers/spi/Makefile
+index 33f9c09..17b4737 100644
 --- a/drivers/spi/Makefile
 +++ b/drivers/spi/Makefile
-@@ -17,6 +17,7 @@ obj-$(CONFIG_SPI_AU1550)             += spi-au1550.
+@@ -17,6 +17,7 @@ obj-$(CONFIG_SPI_AU1550)             += spi-au1550.o
  obj-$(CONFIG_SPI_BCM2835)             += spi-bcm2835.o
  obj-$(CONFIG_SPI_BCM63XX)             += spi-bcm63xx.o
  obj-$(CONFIG_SPI_BFIN5XX)             += spi-bfin5xx.o
@@ -685,6 +706,9 @@ Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
  obj-$(CONFIG_SPI_BFIN_SPORT)          += spi-bfin-sport.o
  obj-$(CONFIG_SPI_BITBANG)             += spi-bitbang.o
  obj-$(CONFIG_SPI_BUTTERFLY)           += spi-butterfly.o
+diff --git a/drivers/spi/spi-bcm2708.c b/drivers/spi/spi-bcm2708.c
+new file mode 100644
+index 0000000..9f1580e
 --- /dev/null
 +++ b/drivers/spi/spi-bcm2708.c
 @@ -0,0 +1,594 @@
@@ -1282,3 +1306,6 @@ Subject: [PATCH 019/174] Backport of Chris Boot's i2c and spi drivers.
 +MODULE_AUTHOR("Chris Boot <bootc@bootc.net>");
 +MODULE_LICENSE("GPL v2");
 +MODULE_ALIAS("platform:" DRV_NAME);
+-- 
+1.9.1
+