[kernel] update to 2.6.25.19, and refresh patches
[openwrt/svn-archive/archive.git] / target / linux / brcm47xx / Makefile
index 11485fe056e84f9532a73b7a317a31e1c33ce024..daa867b4b3b1325852b9d6eb2307fb75b7eee773 100644 (file)
@@ -11,17 +11,14 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.25.19
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += kmod-switch kmod-diag
 
 define Target/Description
        Build firmware images for Broadcom based routers
        (e.g. Netgear WGT634U)
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
-
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))