brcm63xx: create initramfs HCS images
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / Makefile
index 1d544357ae9ef9c77aae591662e0deeaa7f57f0d..0d2389ab49bf5293aed650d1475f98443df8792f 100644 (file)
@@ -9,13 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.37.6
+SUBTARGETS:=generic smp
+FEATURES:=squashfs usb atm pci pcmcia
+LINUX_VERSION:=3.9.4
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-switch gpioctl kmod-input-gpio-buttons \
-       kmod-leds-gpio kmod-button-hotplug
+DEFAULT_PACKAGES += swconfig kmod-input-gpio-keys-polled kmod-button-hotplug
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers