bcm63xx: enable bcm6328 support and required drivers
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / Makefile
index 9b9043269f12f2b64a8dc2182fd0edb7cde602db..2fdd5695713f9a41505a2062ea0d6d0136657a74 100644 (file)
@@ -10,11 +10,13 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.35.9
+LINUX_VERSION:=3.3.7
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-switch gpioctl
+DEFAULT_PACKAGES += kmod-switch kmod-input-gpio-keys-polled \
+       kmod-button-hotplug
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers