build: add a config option for enabling a testing version of the target kernel
[openwrt/staging/dedeckeh.git] / target / linux / cns3xxx / Makefile
index 27ed12f2f78260550a0228a25c71daafdb0916f1..785b06f596b4df15c96e78f9fc7a7016541babe1 100644 (file)
@@ -12,19 +12,20 @@ BOARDNAME:=Cavium Networks Econa CNS3xxx
 FEATURES:=squashfs fpu gpio pcie usb usbgadget
 CPU_TYPE:=mpcore
 CPU_SUBTYPE:=vfp
-MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
-
-KERNEL_PATCHVER:=3.10
-
-include $(INCLUDE_DIR)/target.mk
+MAINTAINER:=Felix Fietkau <nbd@nbd.name>, \
+           Koen Vandeputte <koen.vandeputte@ncentric.com>
+KERNEL_PATCHVER:=4.14
+KERNEL_TESTING_PATCHVER := 4.19
 
 define Target/Description
        Build images for Cavium Networks Econa CNS3xxx based boards,
        eg. the Gateworks Laguna family
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 KERNELNAME:=zImage
 
-DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
+DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-basic
 
 $(eval $(call BuildTarget))