target: use SPDX license identifiers on Makefiles
[openwrt/staging/chunkeey.git] / target / linux / gemini / image / Makefile
index 80a698927c95504b1bd061bb6d5060fa749d18f7..9906808c9ed0db01a8bc4dea984f4da78fe48a36 100644 (file)
@@ -1,9 +1,7 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2009-2018 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
@@ -130,7 +128,6 @@ define Device/Default
        KERNEL_NAME := zImage
        KERNEL := kernel-bin | append-dtb
        BLOCKSIZE := 128k
-       SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
 endef
 
 # A reasonable set of default packages handling the NAS type
@@ -141,7 +138,7 @@ GEMINI_NAS_PACKAGES := $(DEFAULT_PACKAGES.nas) \
                kmod-fs-btrfs kmod-fs-cifs kmod-fs-nfs \
                kmod-fs-nfsd kmod-fs-ntfs kmod-fs-reiserfs kmod-fs-vfat \
                kmod-nls-utf8 kmod-usb-storage-extras kmod-hwmon-drivetemp \
-               samba36-server cfdisk e2fsprogs badblocks \
+               cfdisk e2fsprogs badblocks \
                partx-utils
 
 # The DIR-685 flash layout is kernel in WRGG format, padded and followed
@@ -171,7 +168,6 @@ define Device/dlink_dns-313
        DEVICE_VENDOR := D-Link
        DEVICE_MODEL := DNS-313 1-Bay Network Storage Enclosure
        DEVICE_DTS := gemini-dlink-dns-313
-       DEVICE_TYPE := nas
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
        BLOCKSIZE := 1k
        FILESYSTEMS := ext4
@@ -204,7 +200,6 @@ define Device/raidsonic_ib-4220-b
        DEVICE_VENDOR := Raidsonic
        DEVICE_MODEL := NAS IB-4220-B
        DEVICE_DTS := gemini-nas4220b
-       DEVICE_TYPE := nas
 endef
 TARGET_DEVICES += raidsonic_ib-4220-b