target: use SPDX license identifiers on Makefiles
[openwrt/staging/chunkeey.git] / target / linux / gemini / image / Makefile
index b631452a0ffb63984fb86329f1f1bf27668c965f..9906808c9ed0db01a8bc4dea984f4da78fe48a36 100644 (file)
@@ -1,23 +1,33 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2009-2018 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+define Build/copy-kernel.bin
+       $(call locked,$(MAKE) -C copy-kernel CROSS_COMPILE=$(TARGET_CROSS) O=$(KDIR),gemini-copy-kernel.bin)
+endef
+
 # Cook a "WRGG" image, this board is apparently one in the D-Link
 # WRGG family and uses the exact same firmware format as other
 # D-Link devices.
-define Build/dir685-images
-       mkwrggimg -i $(IMAGE_KERNEL) \
-       -o $(BIN_DIR)/$(IMG_PREFIX)-dir685-fwupdate.bin \
+define Build/dir685-image
+       mkwrggimg -i $@ \
+       -o $@.new \
        -d /dev/mtdblock/1 \
        -s wrgns01_dlwbr_dir685RBWW \
        -v 'N/A' \
        -m dir685 \
        -B 96bb
+
+       mv $@.new $@
+endef
+
+# Padding added after the rootfs to an even 128k boundary
+# as this is 128k eraseblocks flash.
+define Build/dir685-pad-rootfs
+       $(STAGING_DIR_HOST)/bin/padjffs2 $(IMAGE_ROOTFS) -c 128 >>$@
 endef
 
 # Build D-Link DNS-313 images using the special header tool.
@@ -25,33 +35,79 @@ endef
 # to satisfy the boot loader on the device. The zImage is
 # the only real content.
 define Build/dns313-images
-       if [ -d $(BIN_DIR)/.boot ] ; then rm -rf $(BIN_DIR)/.boot ; fi
-       mkdir -p $(BIN_DIR)/.boot
-       echo "dummy" > $(BIN_DIR)/.boot/dummyfile
-       dns313-header $(BIN_DIR)/.boot/dummyfile \
-               $(BIN_DIR)/.boot/rootfs.tgz
-       dns313-header $(BIN_DIR)/.boot/dummyfile \
-               $(BIN_DIR)/.boot/rd.gz
+       mkdir -p $@.tmp/.boot
+       chmod 755 $@.tmp/.boot
+
+       echo "dummy" > $@.tmp/dummyfile
+
+       dns313-header $@.tmp/dummyfile \
+               $@.tmp/.boot/rootfs.tgz
+       dns313-header $@.tmp/dummyfile \
+               $@.tmp/.boot/rd.gz
        dns313-header $(IMAGE_KERNEL) \
-               $(BIN_DIR)/.boot/zImage
-       rm -f $(BIN_DIR)/.boot/dummyfile
-       (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-dns313-bootpart.tar.gz .boot)
-       if [ -d $(BIN_DIR)/.boot ] ; then rm -rf $(BIN_DIR)/.boot ; fi
-endef
-
-# Create the special NAS4220B image format with the squashfs
-# split across two "partitions" named rd.gz and hddapp.tgz but
-# essentially just being used by OpenWRT as one big partition
-define Build/nas4220b-images
-       dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/rd.gz bs=6144k conv=sync
-       dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1 seek=1
-       cp $(IMAGE_KERNEL) $(BIN_DIR)/zImage
-       cp ./ImageInfo-ib4220 $(BIN_DIR)/ImageInfo
-       (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-sysupgrade-ib4220b.tar.gz ImageInfo zImage rd.gz hddapp.tgz)
-       mv $(BIN_DIR)/rd.gz $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-rd.gz
-       mv $(BIN_DIR)/hddapp.tgz $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-hddapp.tgz
-       mv $(BIN_DIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-zImage
-       rm -f $(BIN_DIR)/ImageInfo
+               $@.tmp/.boot/zImage
+
+       rm $@.tmp/dummyfile
+
+       genext2fs --block-size $(BLOCKSIZE:%k=%Ki) \
+               --size-in-blocks $$((1024 * $(CONFIG_TARGET_KERNEL_PARTSIZE))) \
+               --squash-uids \
+               --root $@.tmp $@.tmp-boot
+
+       # The device firmware needs revision 1 of EXT2
+       tune2fs -O filetype $@.tmp-boot
+       e2fsck -pDf $@.tmp-boot > /dev/null
+
+       ./dns313_gen_hdd_img.sh $@ $@.tmp-boot $(IMAGE_ROOTFS) \
+               $(CONFIG_TARGET_KERNEL_PARTSIZE) \
+               $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+
+       rm -rf $@.tmp
+endef
+
+define Build/wiligear-image
+       $(STAGING_DIR_HOST)/bin/mkfwimage2 \
+               -m GEOS -f 0x30000000 -z \
+               -v $(1).v5.00.SL3512.OpenWrt.00000.000000.000000 \
+               -p Kernel:0x020000:0x100000:0:0:$(IMAGE_KERNEL) \
+               -p Ramdisk:0x120000:0x500000:0:0:$@ \
+               -o $@.new
+
+       mv $@.new $@
+endef
+
+# Create the default image format used by the StorLink reference design
+# SL93512r, Raidsonic NAS4220B and Itian Square One SQ201
+# with the squashfs and overlay inside the "application" partition.
+#
+# These devices have a hard-coded partition table that the boot loader
+# constantly reflashes back, so we need to work around it like this:
+#
+# 0x000000120000-0x000000320000 : "Kern" - small copy routine and first
+#                                 part of the kernel goes here
+# 0x000000320000-0x000000920000 : "Ramdisk" - second part of the kernel and
+#                                 some padding goes here
+# 0x000000920000-0x000000f20000 : "Application" - rootfs goes here
+define Build/storlink-default-images
+       mkdir -p $@.tmp
+
+       # "App" partition is the rootfs
+       mv $@ $@.tmp/hddapp.tgz
+       # 256 bytes copy routine
+       dd if=$(KDIR)/copy-kernel.bin of=$@.tmp/zImage
+       $(call Image/pad-to,$@.tmp/zImage,512)
+       # Copy first part of the kernel into zImage
+       dd if=$(IMAGE_KERNEL) of=$@.tmp/zImage bs=1 seek=512 count=2096640
+       # Put the rest of the kernel into the "ramdisk"
+       dd if=$(IMAGE_KERNEL) of=$@.tmp/rd.gz bs=1 skip=2096640 count=6144k conv=sync
+       cp ./ImageInfo-$(1) $@.tmp/ImageInfo
+
+       sed -i -e "s/DATESTR/`date +%Y%m%d $(if $(SOURCE_DATE_EPOCH),--date "@$(SOURCE_DATE_EPOCH)")`/g" $@.tmp/ImageInfo
+
+       (cd $@.tmp; tar --sort=name --owner=0 --group=0 --numeric-owner -czf $@ * \
+               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)"))
+
+       rm -rf $@.tmp
 endef
 
 # WBD-111 and WBD-222:
@@ -67,72 +123,119 @@ endef
 
 # All DTB files are prefixed with "gemini-"
 define Device/Default
-       DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
+       PROFILES := Default
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_NAME := zImage
        KERNEL := kernel-bin | append-dtb
-       FILESYSTEMS := squashfs
-       IMAGE_NAME := $$(IMAGE_PREFIX)-$$(1).$$(2)
        BLOCKSIZE := 128k
-       PAGESIZE := 2048
 endef
 
 # A reasonable set of default packages handling the NAS type
 # of devices out of the box (former NAS42x0 IcyBox defaults)
-GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
+GEMINI_NAS_PACKAGES := $(DEFAULT_PACKAGES.nas) \
+               kmod-md-mod kmod-md-linear kmod-md-multipath \
                kmod-md-raid0 kmod-md-raid1 kmod-md-raid10 kmod-md-raid456 \
                kmod-fs-btrfs kmod-fs-cifs kmod-fs-nfs \
                kmod-fs-nfsd kmod-fs-ntfs kmod-fs-reiserfs kmod-fs-vfat \
-               kmod-nls-utf8 kmod-usb-storage-extras \
-               samba36-server mdadm cfdisk fdisk e2fsprogs badblocks
+               kmod-nls-utf8 kmod-usb-storage-extras kmod-hwmon-drivetemp \
+               cfdisk e2fsprogs badblocks \
+               partx-utils
 
-define Device/dlink-dir-685
-       DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
+# The DIR-685 flash layout is kernel in WRGG format, padded and followed
+# by the appended rootfs followed by some reasonable JFFS padding, the
+# remainder will be used by JFFS2 through overlayfs.
+#
+# - For the factory image, the WRGG image includes the rootfs so that the
+#   default firmware will flash it properly as all it knows is WRGG format.
+# - For the sysupgrade, we do not include the rootfs in the kernel image
+#   so it is not needelessly tossed into the RAM by the boot loader.
+#   This will be flashed from OpenWrt userland anyways so we only need
+#   the minimum to make the boot loader happy.
+define Device/dlink_dir-685
+       DEVICE_VENDOR := D-Link
+       DEVICE_MODEL := DIR-685 Xtreme N Storage Router
+       DEVICE_DTS := gemini-dlink-dir-685
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
-                       kmod-switch-rtl8366rb swconfig
-       IMAGES += dir685-image
-       IMAGE/dir685-image := dir685-images
+                       kmod-rt2800-pci
+       IMAGES := factory.bin sysupgrade.bin
+       # Pad to 128k erase blocks with 160 bytes WRGG header
+       IMAGE/factory.bin := append-kernel | pad-offset 128k 160 | append-rootfs | dir685-pad-rootfs | dir685-image
+       IMAGE/sysupgrade.bin := append-kernel | pad-offset 128k 160 | dir685-image | append-rootfs | dir685-pad-rootfs | append-metadata
 endef
-TARGET_DEVICES += dlink-dir-685
+TARGET_DEVICES += dlink_dir-685
 
-define Device/dlink-dns-313
-       DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
+define Device/dlink_dns-313
+       DEVICE_VENDOR := D-Link
+       DEVICE_MODEL := DNS-313 1-Bay Network Storage Enclosure
+       DEVICE_DTS := gemini-dlink-dns-313
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
-       IMAGES += dns313-image
-       IMAGE/dns313-image := dns313-images
+       BLOCKSIZE := 1k
+       FILESYSTEMS := ext4
+       IMAGES := factory.bin.gz
+       IMAGE/factory.bin.gz := dns313-images | gzip
 endef
-TARGET_DEVICES += dlink-dns-313
+TARGET_DEVICES += dlink_dns-313
 
-define Device/nas4220b
-       DEVICE_TITLE := Raidsonic NAS IB-4220-B
-       IMAGES += nas4220b-image
-       IMAGE/nas4220b-image := nas4220b-images
+# Default images setup used by the StorLink reference designs
+define Device/storlink-reference
+       COMPILE := copy-kernel-$(1).bin
+       COMPILE/copy-kernel-$(1).bin := copy-kernel.bin
+       IMAGES := factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 6144k | \
+               storlink-default-images $(1)
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
 endef
-TARGET_DEVICES += nas4220b
 
-define Device/rut1xx
-       DEVICE_TITLE := Teltonika RUT1xx
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
+define Device/itian_sq201
+       $(Device/storlink-reference)
+       DEVICE_VENDOR := ITian
+       DEVICE_MODEL := Square One SQ201
+       DEVICE_DTS := gemini-sq201
+       DEVICE_PACKAGES += kmod-rt61-pci kmod-usb2-pci
+endef
+TARGET_DEVICES += itian_sq201
+
+define Device/raidsonic_ib-4220-b
+       $(Device/storlink-reference)
+       DEVICE_VENDOR := Raidsonic
+       DEVICE_MODEL := NAS IB-4220-B
+       DEVICE_DTS := gemini-nas4220b
 endef
-TARGET_DEVICES += rut1xx
+TARGET_DEVICES += raidsonic_ib-4220-b
 
-define Device/sq201
-       DEVICE_TITLE := ITian Square One SQ201
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) rt61-pci-firmware
+define Device/storlink_sl93512r
+       $(Device/storlink-reference)
+       DEVICE_VENDOR := StorLink
+       DEVICE_MODEL := SL93512r
+       DEVICE_DTS := gemini-sl93512r
 endef
-TARGET_DEVICES += sq201
+TARGET_DEVICES += storlink_sl93512r
+
 
-define Device/wbd111
-       DEVICE_TITLE := Wiliboard WBD-111
+# The wiliboard images need some changes to be functional and buildable.
+#
+# The dts would need to use the ecoscentric,redboot-fis-partitions partition
+# parser to get the correct partition offsets and size.
+#
+# The mkfwimage2 call need to be adjusted to reflect the real size of kernel
+# and rootfs. It is expected that the OEM firmware adjusts the on flash
+# partition table with the values defined in the image header.
+define Device/wiliboard_wbd111
+       DEVICE_VENDOR := Wiliboard
+       DEVICE_MODEL := WBD-111
+       DEVICE_DTS := gemini-wbd111
        KERNEL := kernel-bin | append-dtb | wbd-nops
+       IMAGES := factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | wiligear-image "WILI-S.WILIBOARD"
 endef
-TARGET_DEVICES += wbd111
 
-define Device/wbd222
-       DEVICE_TITLE := Wiliboard WBD-222
+define Device/wiliboard_wbd222
+       DEVICE_VENDOR := Wiliboard
+       DEVICE_MODEL := WBD-222
+       DEVICE_DTS := gemini-wbd222
        KERNEL := kernel-bin | append-dtb | wbd-nops
+       IMAGES := factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | wiligear-image "WILI-S.WBD222"
 endef
-TARGET_DEVICES += wbd222
 
 $(eval $(call BuildImage))