kernel: update act_ctinfo
[openwrt/staging/rmilecki.git] / target / linux / generic / backport-4.19 / 380-v5.3-net-sched-Introduce-act_ctinfo-action.patch
index 632f41ef98bd6b93bad3e96d6b6265974cff5987..1d8694f6f81d805fbd544d14d5951a627dbb0903 100644 (file)
@@ -1,4 +1,4 @@
-From 402c8d61d2f27060be14849fcb30682f75f3bf3b Mon Sep 17 00:00:00 2001
+From c17877e414155b9b97d10416ff62b102d25019a1 Mon Sep 17 00:00:00 2001
 From: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
 Date: Wed, 13 Mar 2019 20:54:49 +0000
 Subject: [PATCH] net: sched: Introduce act_ctinfo action
@@ -59,9 +59,9 @@ e.g. dscp 0xfc000000/0x01000000
 
 Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
 ---
- include/net/tc_act/tc_ctinfo.h            |  28 ++
+ include/net/tc_act/tc_ctinfo.h            |  33 ++
  include/uapi/linux/pkt_cls.h              |   3 +-
- include/uapi/linux/tc_act/tc_ctinfo.h     |  34 ++
+ include/uapi/linux/tc_act/tc_ctinfo.h     |  29 ++
  net/sched/Kconfig                         |  17 +
  net/sched/Makefile                        |   1 +
  net/sched/act_ctinfo.c                    | 395 ++++++++++++++++++++++
@@ -73,10 +73,10 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
 
 diff --git a/include/net/tc_act/tc_ctinfo.h b/include/net/tc_act/tc_ctinfo.h
 new file mode 100644
-index 000000000000..d6a688571672
+index 000000000000..f071c1d70a25
 --- /dev/null
 +++ b/include/net/tc_act/tc_ctinfo.h
-@@ -0,0 +1,28 @@
+@@ -0,0 +1,33 @@
 +/* SPDX-License-Identifier: GPL-2.0 */
 +#ifndef __NET_TC_CTINFO_H
 +#define __NET_TC_CTINFO_H
@@ -102,6 +102,11 @@ index 000000000000..d6a688571672
 +      u64 stats_cpmark_set;
 +};
 +
++enum {
++      CTINFO_MODE_DSCP        = BIT(0),
++      CTINFO_MODE_CPMARK      = BIT(1)
++};
++
 +#define to_ctinfo(a) ((struct tcf_ctinfo *)a)
 +
 +#endif /* __NET_TC_CTINFO_H */
@@ -121,10 +126,10 @@ index be382fb0592d..71e10c5a96a0 100644
  #define TCA_ID_MAX __TCA_ID_MAX
 diff --git a/include/uapi/linux/tc_act/tc_ctinfo.h b/include/uapi/linux/tc_act/tc_ctinfo.h
 new file mode 100644
-index 000000000000..da803e05a89b
+index 000000000000..f5f26d95d0e7
 --- /dev/null
 +++ b/include/uapi/linux/tc_act/tc_ctinfo.h
-@@ -0,0 +1,34 @@
+@@ -0,0 +1,29 @@
 +/* SPDX-License-Identifier: GPL-2.0 WITH Linux-syscall-note */
 +#ifndef __UAPI_TC_CTINFO_H
 +#define __UAPI_TC_CTINFO_H
@@ -153,11 +158,6 @@ index 000000000000..da803e05a89b
 +
 +#define TCA_CTINFO_MAX (__TCA_CTINFO_MAX - 1)
 +
-+enum {
-+      CTINFO_MODE_DSCP        = BIT(0),
-+      CTINFO_MODE_CPMARK      = BIT(1)
-+};
-+
 +#endif
 diff --git a/net/sched/Kconfig b/net/sched/Kconfig
 index e95741388311..1d79d5dba6e4 100644