generic: 6.6: refresh hack patches
[openwrt/staging/wigyori.git] / target / linux / generic / hack-6.6 / 212-tools_portability.patch
index 4671e7512893d0601cb0b04a5090473e76befaa3..ec10f4b966734d3110ec84cf7ab034c6cc876f6c 100644 (file)
@@ -73,7 +73,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  struct page;
  struct kmem_cache;
-@@ -51,7 +55,9 @@ typedef __s8  s8;
+@@ -56,7 +60,9 @@ typedef __s8  s8;
  #define __user
  #endif
  #define __must_check
@@ -85,7 +85,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  typedef __u16 __bitwise __be16;
 --- a/tools/perf/pmu-events/jevents.py
 +++ b/tools/perf/pmu-events/jevents.py
-@@ -684,6 +684,7 @@ def main() -> None:
+@@ -1197,6 +1197,7 @@ such as "arm/cortex-a34".''',
  #include "util/header.h"
  #include "util/pmu.h"
  #include <string.h>
@@ -107,7 +107,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #if defined(__BYTE_ORDER) ? __BYTE_ORDER == __LITTLE_ENDIAN : defined(__LITTLE_ENDIAN)
 --- a/tools/arch/x86/include/asm/orc_types.h
 +++ b/tools/arch/x86/include/asm/orc_types.h
-@@ -40,7 +40,6 @@
+@@ -46,7 +46,6 @@
  #define ORC_TYPE_REGS_PARTIAL         4
  
  #ifndef __ASSEMBLY__
@@ -115,7 +115,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  /*
   * This struct is more or less a vastly simplified version of the DWARF Call
-@@ -53,12 +52,12 @@
+@@ -59,12 +58,12 @@
  struct orc_entry {
        s16             sp_offset;
        s16             bp_offset;
@@ -199,7 +199,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        unsigned long  __rb_parent_color;
 --- a/tools/objtool/Makefile
 +++ b/tools/objtool/Makefile
-@@ -40,7 +40,7 @@ include ../scripts/Makefile.arch
+@@ -40,7 +40,7 @@ elfshdr := $(shell echo '$(pound)include
  OBJTOOL_CFLAGS += $(if $(elfshdr),,-DLIBELF_USE_DEPRECATED)
  
  # Always want host compilation.
@@ -208,7 +208,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  AWK = awk
  MKDIR = mkdir
-@@ -43,6 +43,7 @@ BUILD_ORC := n
+@@ -55,6 +55,7 @@ BUILD_ORC := n
  
  ifeq ($(SRCARCH),x86)
        BUILD_ORC := y
@@ -218,7 +218,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  export BUILD_ORC
 --- a/tools/objtool/check.c
 +++ b/tools/objtool/check.c
-@@ -1164,11 +1164,12 @@ static int add_ignore_alternatives(struc
+@@ -1288,11 +1288,12 @@ static int add_ignore_alternatives(struc
        return 0;
  }
  
@@ -232,7 +232,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  {
        return false;
  }
-@@ -1177,7 +1178,7 @@ __weak bool arch_is_retpoline(struct sym
+@@ -1301,7 +1302,7 @@ __weak bool arch_is_retpoline(struct sym
   * Symbols that replace INSN_RETURN, every (tail) call to such a symbol
   * will be added to the .return_sites section.
   */
@@ -241,7 +241,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  {
        return false;
  }
-@@ -1186,10 +1187,11 @@ __weak bool arch_is_rethunk(struct symbo
+@@ -1310,10 +1311,11 @@ __weak bool arch_is_rethunk(struct symbo
   * Symbols that are embedded inside other instructions, because sometimes crazy
   * code exists. These are mostly ignored for validation purposes.
   */
@@ -297,7 +297,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                          struct instruction *insn)
 --- a/tools/objtool/special.c
 +++ b/tools/objtool/special.c
-@@ -54,9 +54,11 @@ struct special_entry entries[] = {
+@@ -54,9 +54,11 @@ static const struct special_entry entrie
        {},
  };