kernel: refresh patches for kernel 3.0-rc4
[openwrt/svn-archive/archive.git] / target / linux / generic / patches-2.6.36 / 402-ledtrig_netdev.patch
index 57f071ba7bdeb5067edaf8df9faffaebe2a85398..d229a2e4206ed99359cf5b85f9d42a3dfba314af 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -375,4 +375,11 @@ config LEDS_TRIGGER_MORSE
+@@ -384,4 +384,11 @@ config LEDS_TRIGGER_MORSE
        tristate "LED Morse Trigger"
        depends on LEDS_TRIGGERS
  
  endif # NEW_LEDS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -49,3 +49,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += 
+@@ -50,3 +50,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += 
  obj-$(CONFIG_LEDS_TRIGGER_GPIO)               += ledtrig-gpio.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
  obj-$(CONFIG_LEDS_TRIGGER_MORSE)      += ledtrig-morse.o
-+obj-$(CONFIG_LEDS_TRIGGER_NETDEV)      += ledtrig-netdev.o
-
++obj-$(CONFIG_LEDS_TRIGGER_NETDEV)     += ledtrig-netdev.o
 --- a/drivers/leds/ledtrig-netdev.c
 +++ b/drivers/leds/ledtrig-netdev.c
-@@ -309,6 +309,7 @@ static void netdev_trig_timer(unsigned l
+@@ -307,8 +307,9 @@ done:
+ static void netdev_trig_timer(unsigned long arg)
+ {
        struct led_netdev_data *trigger_data = (struct led_netdev_data *)arg;
-       const struct net_device_stats *dev_stats;
+-      const struct net_device_stats *dev_stats;
++      struct rtnl_link_stats64 *dev_stats;
        unsigned new_activity;
 +      struct rtnl_link_stats64 temp;