mips: use -mno-branch-likely for kernel and userspace, saves ~11k kernel size after...
[openwrt/staging/stintel.git] / target / linux / generic / patches-3.6 / 305-mips_module_reloc.patch
index fea4a0012939973df964686c46aa883fea0b716e..a2738dca7e4b6adc798bbe7f37a1348cef114aa0 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
 @@ -90,8 +90,8 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
- cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe
+ cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
  cflags-y                      += -msoft-float
  LDFLAGS_vmlinux                       += -G 0 -static -n -nostdlib
 -KBUILD_AFLAGS_MODULE          += -mlong-calls