kernel: backport 5.13 mtd partitioning changes
[openwrt/staging/dedeckeh.git] / target / linux / generic / pending-5.10 / 435-mtd-add-routerbootpart-parser-config.patch
index 7853cae3257e1ba5898b3fae4dd2885465e0681e..ab1e09a5f129d991b87e75fea8a2750becb8d987 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
 
 --- a/drivers/mtd/parsers/Kconfig
 +++ b/drivers/mtd/parsers/Kconfig
-@@ -185,3 +185,12 @@ config MTD_REDBOOT_PARTS_READONLY
+@@ -195,3 +195,12 @@ config MTD_REDBOOT_PARTS_READONLY
          'FIS directory' images, enable this option.
  
  endif # MTD_REDBOOT_PARTS
@@ -31,7 +31,7 @@ Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
 +       formatted DTS.
 --- a/drivers/mtd/parsers/Makefile
 +++ b/drivers/mtd/parsers/Makefile
-@@ -12,3 +12,4 @@ obj-$(CONFIG_MTD_AFS_PARTS)          += afs.o
+@@ -13,3 +13,4 @@ obj-$(CONFIG_MTD_AFS_PARTS)          += afs.o
  obj-$(CONFIG_MTD_PARSER_TRX)          += parser_trx.o
  obj-$(CONFIG_MTD_SHARPSL_PARTS)               += sharpslpart.o
  obj-$(CONFIG_MTD_REDBOOT_PARTS)               += redboot.o