refresh generic-2.4 patches
[openwrt/staging/dedeckeh.git] / target / linux / generic-2.4 / patches / 201-hfc_usb_backport.patch
index 302f6bbee39dd71718ae937a6f95b741a7af3d30..af084d8197df2a85f607add2b9e15d7dccd25589 100644 (file)
@@ -1,8 +1,8 @@
 Index: linux-2.4.35.4/drivers/Makefile
 ===================================================================
---- linux-2.4.35.4.orig/drivers/Makefile       2007-12-15 05:19:39.306660996 +0100
-+++ linux-2.4.35.4/drivers/Makefile    2007-12-15 05:19:59.111789629 +0100
-@@ -38,7 +38,7 @@
+--- linux-2.4.35.4.orig/drivers/Makefile
++++ linux-2.4.35.4/drivers/Makefile
+@@ -38,7 +38,7 @@ subdir-$(CONFIG_FUSION)              += message/fusi
  subdir-$(CONFIG_MD)           += md
  subdir-$(CONFIG_IEEE1394)     += ieee1394
  subdir-$(CONFIG_PNP)          += pnp
@@ -13,8 +13,8 @@ Index: linux-2.4.35.4/drivers/Makefile
  
 Index: linux-2.4.35.4/drivers/isdn/hisax/hfc_usb.c
 ===================================================================
---- linux-2.4.35.4.orig/drivers/isdn/hisax/hfc_usb.c   2007-12-15 05:19:55.575588111 +0100
-+++ linux-2.4.35.4/drivers/isdn/hisax/hfc_usb.c        2007-12-15 05:19:59.115789855 +0100
+--- linux-2.4.35.4.orig/drivers/isdn/hisax/hfc_usb.c
++++ linux-2.4.35.4/drivers/isdn/hisax/hfc_usb.c
 @@ -1,13 +1,11 @@
 -/* $Id: hfc_usb.c,v 2.3 2001/07/06 21:30:11 werner Exp $
 +/*
@@ -477,7 +477,7 @@ Index: linux-2.4.35.4/drivers/isdn/hisax/hfc_usb.c
        }
  }                             /* ctrl_start_transfer */
  
-@@ -293,897 +275,1418 @@
+@@ -293,897 +275,1418 @@ ctrl_start_transfer(hfcusb_data * hfc)
  /* queue a control transfer request */
  /* return 0 on success.             */
  /************************************/