refresh generic-2.4 patches
[openwrt/staging/dedeckeh.git] / target / linux / generic-2.4 / patches / 601-netfilter_ipp2p_0.8.1rc1.patch
index c2b519963071b8efee736ea53b0905b09df5a0f1..1c9ce764776f20af60dbb466d5077e73c3fa3285 100644 (file)
@@ -1,7 +1,7 @@
 Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_ipp2p.h
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_ipp2p.h    2007-12-15 05:20:05.756168270 +0100
+--- /dev/null
++++ linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_ipp2p.h
 @@ -0,0 +1,31 @@
 +#ifndef __IPT_IPP2P_H
 +#define __IPT_IPP2P_H
@@ -36,9 +36,9 @@ Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_ipp2p.h
 +#define IPP2P_XDCC            (1 << 16)
 Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
 ===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/Config.in   2007-12-15 05:19:38.466613124 +0100
-+++ linux-2.4.35.4/net/ipv4/netfilter/Config.in        2007-12-15 05:20:05.764168722 +0100
-@@ -26,6 +26,7 @@
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/Config.in
++++ linux-2.4.35.4/net/ipv4/netfilter/Config.in
+@@ -26,6 +26,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ]; 
    dep_tristate '  TOS match support' CONFIG_IP_NF_MATCH_TOS $CONFIG_IP_NF_IPTABLES
    dep_tristate '  recent match support' CONFIG_IP_NF_MATCH_RECENT $CONFIG_IP_NF_IPTABLES
    dep_tristate '  ECN match support' CONFIG_IP_NF_MATCH_ECN $CONFIG_IP_NF_IPTABLES
@@ -48,9 +48,9 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
   
 Index: linux-2.4.35.4/net/ipv4/netfilter/Makefile
 ===================================================================
---- linux-2.4.35.4.orig/net/ipv4/netfilter/Makefile    2007-12-15 05:19:38.474613582 +0100
-+++ linux-2.4.35.4/net/ipv4/netfilter/Makefile 2007-12-15 05:20:05.764168722 +0100
-@@ -67,6 +67,7 @@
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/Makefile
++++ linux-2.4.35.4/net/ipv4/netfilter/Makefile
+@@ -67,6 +67,7 @@ obj-$(CONFIG_IP_NF_MATCH_HELPER) += ipt_
  obj-$(CONFIG_IP_NF_MATCH_LIMIT) += ipt_limit.o
  obj-$(CONFIG_IP_NF_MATCH_MARK) += ipt_mark.o
  obj-$(CONFIG_IP_NF_MATCH_MAC) += ipt_mac.o
@@ -60,8 +60,8 @@ Index: linux-2.4.35.4/net/ipv4/netfilter/Makefile
  obj-$(CONFIG_IP_NF_MATCH_MULTIPORT) += ipt_multiport.o
 Index: linux-2.4.35.4/net/ipv4/netfilter/ipt_ipp2p.c
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.4.35.4/net/ipv4/netfilter/ipt_ipp2p.c      2007-12-15 05:20:05.764168722 +0100
+--- /dev/null
++++ linux-2.4.35.4/net/ipv4/netfilter/ipt_ipp2p.c
 @@ -0,0 +1,868 @@
 +#if defined(MODVERSIONS)
 +#include <linux/modversions.h>