merge pptp fix from r15970 to 8.09
[openwrt/svn-archive/archive.git] / target / linux / generic-2.4 / patches / 610-netfilter_connbytes.patch
index 95bc10f2bcd6247ff9dccc76c9134a600b1b45b2..42932f72762634158dbe08613c83332d0bdba881 100644 (file)
@@ -1,6 +1,8 @@
---- linux/net/ipv4/netfilter/Config.in.org     2005-11-13 15:53:59.457222512 +0100
-+++ linux/net/ipv4/netfilter/Config.in 2005-11-13 15:56:25.241060000 +0100
-@@ -11,6 +11,8 @@
+Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
+===================================================================
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/Config.in
++++ linux-2.4.35.4/net/ipv4/netfilter/Config.in
+@@ -11,6 +11,8 @@ if [ "$CONFIG_IP_NF_CONNTRACK" != "n" ];
    dep_tristate '  Amanda protocol support' CONFIG_IP_NF_AMANDA $CONFIG_IP_NF_CONNTRACK
    dep_tristate '  TFTP protocol support' CONFIG_IP_NF_TFTP $CONFIG_IP_NF_CONNTRACK
    dep_tristate '  IRC protocol support' CONFIG_IP_NF_IRC $CONFIG_IP_NF_CONNTRACK
    dep_tristate '  GRE protocol support' CONFIG_IP_NF_CT_PROTO_GRE $CONFIG_IP_NF_CONNTRACK
    dep_tristate '   PPTP protocol support' CONFIG_IP_NF_PPTP $CONFIG_IP_NF_CT_PROTO_GRE
  fi
---- linux/net/ipv4/netfilter/Makefile.org      2005-11-12 16:48:38.000000000 +0100
-+++ linux/net/ipv4/netfilter/Makefile  2005-11-13 15:56:38.663019552 +0100
-@@ -94,6 +94,7 @@
+Index: linux-2.4.35.4/net/ipv4/netfilter/Makefile
+===================================================================
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/Makefile
++++ linux-2.4.35.4/net/ipv4/netfilter/Makefile
+@@ -106,6 +106,7 @@ obj-$(CONFIG_IP_NF_MATCH_LENGTH) += ipt_
  obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
  obj-$(CONFIG_IP_NF_MATCH_STATE) += ipt_state.o
  obj-$(CONFIG_IP_NF_MATCH_CONNMARK) += ipt_connmark.o
 +obj-$(CONFIG_IP_NF_MATCH_CONNBYTES) += ipt_connbytes.o
  obj-$(CONFIG_IP_NF_MATCH_CONNTRACK) += ipt_conntrack.o
  obj-$(CONFIG_IP_NF_MATCH_UNCLEAN) += ipt_unclean.o
- obj-$(CONFIG_IP_NF_MATCH_TCPMSS) += ipt_tcpmss.o
---- linux/net/ipv4/netfilter/ip_conntrack_amanda.c.org 2004-02-18 14:36:32.000000000 +0100
-+++ linux/net/ipv4/netfilter/ip_conntrack_amanda.c     2005-11-13 15:40:00.000000000 +0100
-@@ -75,7 +75,7 @@
+ obj-$(CONFIG_IP_NF_MATCH_STRING) += ipt_string.o
+Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_amanda.c
+===================================================================
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_amanda.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_amanda.c
+@@ -75,7 +75,7 @@ static int help(const struct iphdr *iph,
  
        /* increase the UDP timeout of the master connection as replies from
         * Amanda clients to the server can be quite delayed */
        
        /* Search for "CONNECT " string */
        do {
---- linux/net/ipv4/netfilter/ip_conntrack_proto_tcp.c.org      2003-11-28 19:26:21.000000000 +0100
-+++ linux/net/ipv4/netfilter/ip_conntrack_proto_tcp.c  2005-11-13 15:45:41.045992536 +0100
-@@ -211,7 +211,7 @@
+Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_tcp.c
+===================================================================
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_tcp.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_tcp.c
+@@ -211,7 +211,7 @@ static int tcp_packet(struct ip_conntrac
                        set_bit(IPS_ASSURED_BIT, &conntrack->status);
  
                WRITE_UNLOCK(&tcp_lock);
        }
  
        return NF_ACCEPT;
---- linux/net/ipv4/netfilter/ip_conntrack_proto_udp.c.org      2003-11-28 19:26:21.000000000 +0100
-+++ linux/net/ipv4/netfilter/ip_conntrack_proto_udp.c  2005-11-13 15:47:38.348159896 +0100
-@@ -47,16 +47,16 @@
+Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_udp.c
+===================================================================
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_udp.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_udp.c
+@@ -47,16 +47,16 @@ static unsigned int udp_print_conntrack(
  /* Returns verdict for packet, and may modify conntracktype */
  static int udp_packet(struct ip_conntrack *conntrack,
                      struct iphdr *iph, size_t len,
  
        return NF_ACCEPT;
  }
---- linux/net/ipv4/netfilter/ip_conntrack_standalone.c.org     2005-11-12 16:48:38.000000000 +0100
-+++ linux/net/ipv4/netfilter/ip_conntrack_standalone.c 2005-11-13 15:51:07.608347512 +0100
-@@ -79,6 +79,18 @@
+Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_standalone.c
+===================================================================
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_standalone.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_standalone.c
+@@ -79,6 +79,18 @@ print_expect(char *buffer, const struct 
        return len;
  }
  
@@ -84,7 +96,7 @@
  static unsigned int
  print_conntrack(char *buffer, struct ip_conntrack *conntrack)
  {
-@@ -98,11 +110,15 @@
+@@ -98,11 +110,15 @@ print_conntrack(char *buffer, struct ip_
        len += print_tuple(buffer + len,
                           &conntrack->tuplehash[IP_CT_DIR_ORIGINAL].tuple,
                           proto);
        if (test_bit(IPS_ASSURED_BIT, &conntrack->status))
                len += sprintf(buffer + len, "[ASSURED] ");
        len += sprintf(buffer + len, "use=%u ",
-@@ -478,7 +494,7 @@
+@@ -478,7 +494,7 @@ EXPORT_SYMBOL(ip_conntrack_get);
  EXPORT_SYMBOL(ip_conntrack_helper_register);
  EXPORT_SYMBOL(ip_conntrack_helper_unregister);
  EXPORT_SYMBOL(ip_ct_iterate_cleanup);
  EXPORT_SYMBOL(ip_ct_find_proto);
  EXPORT_SYMBOL(__ip_ct_find_proto);
  EXPORT_SYMBOL(ip_ct_find_helper);
---- linux/net/ipv4/netfilter/ip_conntrack_proto_generic.c.org  2003-11-28 19:26:21.000000000 +0100
-+++ linux/net/ipv4/netfilter/ip_conntrack_proto_generic.c      2005-11-13 15:44:20.734201784 +0100
-@@ -41,9 +41,9 @@
+Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_generic.c
+===================================================================
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_generic.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_generic.c
+@@ -41,9 +41,9 @@ static unsigned int generic_print_conntr
  /* Returns verdict for packet, or -1 for invalid. */
  static int established(struct ip_conntrack *conntrack,
                       struct iphdr *iph, size_t len,
        return NF_ACCEPT;
  }
  
---- linux/net/ipv4/netfilter/ip_conntrack_proto_icmp.c.org     2003-11-28 19:26:21.000000000 +0100
-+++ linux/net/ipv4/netfilter/ip_conntrack_proto_icmp.c 2005-11-13 15:44:50.733641176 +0100
-@@ -82,7 +82,7 @@
+Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_icmp.c
+===================================================================
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_icmp.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_icmp.c
+@@ -82,7 +82,7 @@ static int icmp_packet(struct ip_conntra
                        ct->timeout.function((unsigned long)ct);
        } else {
                atomic_inc(&ct->proto.icmp.count);
        }
  
        return NF_ACCEPT;
---- linux/net/ipv4/netfilter/ip_conntrack_core.c.org   2005-11-12 16:48:38.000000000 +0100
-+++ linux/net/ipv4/netfilter/ip_conntrack_core.c       2005-11-13 15:43:23.882844504 +0100
-@@ -1196,22 +1196,40 @@
+Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_core.c
+===================================================================
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_core.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_core.c
+@@ -1196,22 +1196,40 @@ void ip_conntrack_helper_unregister(stru
  
        MOD_DEC_USE_COUNT;
  }
        }
        WRITE_UNLOCK(&ip_conntrack_lock);
  }
---- linux/include/linux/netfilter_ipv4/ip_conntrack.h.org      2005-11-12 16:48:38.000000000 +0100
-+++ linux/include/linux/netfilter_ipv4/ip_conntrack.h  2005-11-13 15:39:04.000000000 +0100
-@@ -164,6 +164,12 @@
+Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h
+===================================================================
+--- linux-2.4.35.4.orig/include/linux/netfilter_ipv4/ip_conntrack.h
++++ linux-2.4.35.4/include/linux/netfilter_ipv4/ip_conntrack.h
+@@ -164,6 +164,12 @@ struct ip_conntrack_expect
        union ip_conntrack_expect_help help;
  };
  
  struct ip_conntrack_helper;
  
  struct ip_conntrack
-@@ -181,6 +187,12 @@
+@@ -181,6 +187,12 @@ struct ip_conntrack
        /* Timer function; drops refcnt when it goes off. */
        struct timer_list timeout;
  
        /* If we're expecting another related connection, this will be
             in expected linked list */
        struct list_head sibling_list;
-@@ -264,8 +276,10 @@
+@@ -264,8 +276,10 @@ extern int invert_tuplepr(struct ip_conn
                          const struct ip_conntrack_tuple *orig);
  
  /* Refresh conntrack for this many jiffies */
  
  /* These are for NAT.  Icky. */
  /* Call me when a conntrack is destroyed. */
---- linux/net/ipv4/netfilter/ipt_connbytes.c.org       1970-01-01 01:00:00.000000000 +0100
-+++ linux/net/ipv4/netfilter/ipt_connbytes.c   2005-11-13 16:22:02.021433872 +0100
+Index: linux-2.4.35.4/net/ipv4/netfilter/ipt_connbytes.c
+===================================================================
+--- /dev/null
++++ linux-2.4.35.4/net/ipv4/netfilter/ipt_connbytes.c
 @@ -0,0 +1,163 @@
 +/* Kernel module to match connection tracking byte counter.
 + * GPL (C) 2002 Martin Devera (devik@cdi.cz).
 +module_init(init);
 +module_exit(fini);
 +MODULE_LICENSE("GPL");
---- linux/include/linux/netfilter_ipv4/ipt_connbytes.h.org     1970-01-01 01:00:00.000000000 +0100
-+++ linux/include/linux/netfilter_ipv4/ipt_connbytes.h 2005-11-13 16:11:24.567341624 +0100
+Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_connbytes.h
+===================================================================
+--- /dev/null
++++ linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_connbytes.h
 @@ -0,0 +1,25 @@
 +#ifndef _IPT_CONNBYTES_H
 +#define _IPT_CONNBYTES_H
 +};
 +
 +#endif
---- linux-2.4.32/net/ipv4/netfilter/ip_conntrack_proto_gre.c   2006-02-04 19:16:25.000000000 +0100
-+++ /home/florian//openwrt/trunk/openwrt/build_mipsel/linux/net/ipv4/netfilter/ip_conntrack_proto_gre.c        2006-02-04 18:19:08.000000000 +0100
-@@ -237,16 +237,16 @@
+Index: linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_gre.c
+===================================================================
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/ip_conntrack_proto_gre.c
++++ linux-2.4.35.4/net/ipv4/netfilter/ip_conntrack_proto_gre.c
+@@ -237,16 +237,16 @@ static unsigned int gre_print_conntrack(
  /* Returns verdict for packet, and may modify conntrack */
  static int gre_packet(struct ip_conntrack *ct,
                      struct iphdr *iph, size_t len,