[kernel] refresh generic 2.6.22 patches
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.22 / 171-netfilter_tarpit.patch
index 2e5b9e813a7983353d4b2f59b96d1824641f7aed..6e8c260a502a7fa77c59f3f330334131a0da12ec 100644 (file)
@@ -1,7 +1,7 @@
-Index: linux-2.6.22.18/net/netfilter/Kconfig
+Index: linux-2.6.22.19/net/netfilter/Kconfig
 ===================================================================
---- linux-2.6.22.18.orig/net/netfilter/Kconfig
-+++ linux-2.6.22.18/net/netfilter/Kconfig
+--- linux-2.6.22.19.orig/net/netfilter/Kconfig
++++ linux-2.6.22.19/net/netfilter/Kconfig
 @@ -379,6 +379,23 @@ config NETFILTER_XT_TARGET_CONNSECMARK
  
          To compile it as a module, choose M here.  If unsure, say N.
@@ -26,10 +26,10 @@ Index: linux-2.6.22.18/net/netfilter/Kconfig
  config NETFILTER_XT_TARGET_TCPMSS
        tristate '"TCPMSS" target support'
        depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
-Index: linux-2.6.22.18/net/netfilter/Makefile
+Index: linux-2.6.22.19/net/netfilter/Makefile
 ===================================================================
---- linux-2.6.22.18.orig/net/netfilter/Makefile
-+++ linux-2.6.22.18/net/netfilter/Makefile
+--- linux-2.6.22.19.orig/net/netfilter/Makefile
++++ linux-2.6.22.19/net/netfilter/Makefile
 @@ -45,6 +45,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFQUEUE
  obj-$(CONFIG_NETFILTER_XT_TARGET_NFLOG) += xt_NFLOG.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
@@ -38,10 +38,10 @@ Index: linux-2.6.22.18/net/netfilter/Makefile
  obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_CONNSECMARK) += xt_CONNSECMARK.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_CHAOS) += xt_CHAOS.o
-Index: linux-2.6.22.18/net/netfilter/xt_TARPIT.c
+Index: linux-2.6.22.19/net/netfilter/xt_TARPIT.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.22.18/net/netfilter/xt_TARPIT.c
++++ linux-2.6.22.19/net/netfilter/xt_TARPIT.c
 @@ -0,0 +1,280 @@
 +/*
 + * Kernel module to capture and hold incoming TCP connections using