Fix divisor settings for external devices like wireless devices, thanks sn9
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.22 / 600-eeprom_93cx6.patch
index ff23846b47f3bb2e1029d0f7f5239c4a32c9cb9f..205ede2b51e94aeda3479458e69d441172cc55d4 100644 (file)
@@ -12,11 +12,9 @@ Signed-off-by: Michael Wu <flamingice@sourmilk.net>
 Signed-off-by: John W. Linville <linville@tuxdriver.com>
 ---
 
-diff --git a/drivers/misc/Kconfig b/drivers/misc/Kconfig
-index 616eee9..bd601ef 100644
 --- a/drivers/misc/Kconfig
 +++ b/drivers/misc/Kconfig
-@@ -34,6 +34,11 @@ config PHANTOM
+@@ -34,6 +34,11 @@
          If you choose to build module, its name will be phantom. If unsure,
          say N here.
  
@@ -28,24 +26,19 @@ index 616eee9..bd601ef 100644
  
          If unsure, say N.
  
-@@ -187,5 +192,4 @@ config THINKPAD_ACPI_BAY
+@@ -187,5 +192,4 @@
  
          If you are not sure, say Y here.
  
 -
  endmenu
-diff --git a/drivers/misc/Makefile b/drivers/misc/Makefile
-index 8abbf2f..b5ce0e3 100644
 --- a/drivers/misc/Makefile
 +++ b/drivers/misc/Makefile
-@@ -14,3 +14,4 @@ obj-$(CONFIG_PHANTOM)                += phantom.o
+@@ -14,3 +14,4 @@
  obj-$(CONFIG_SGI_IOC4)                += ioc4.o
  obj-$(CONFIG_SONY_LAPTOP)     += sony-laptop.o
  obj-$(CONFIG_THINKPAD_ACPI)   += thinkpad_acpi.o
 +obj-$(CONFIG_EEPROM_93CX6)    += eeprom_93cx6.o
-diff --git a/drivers/misc/eeprom_93cx6.c b/drivers/misc/eeprom_93cx6.c
-new file mode 100644
-index 0000000..bfcb434
 --- /dev/null
 +++ b/drivers/misc/eeprom_93cx6.c
 @@ -0,0 +1,229 @@
@@ -278,9 +271,6 @@ index 0000000..bfcb434
 +}
 +EXPORT_SYMBOL_GPL(eeprom_93cx6_multiread);
 +
-diff --git a/include/linux/eeprom_93cx6.h b/include/linux/eeprom_93cx6.h
-new file mode 100644
-index 0000000..d774b77
 --- /dev/null
 +++ b/include/linux/eeprom_93cx6.h
 @@ -0,0 +1,72 @@