The attached patch adds building of firmware
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.25 / 902-darwin_scripts_include.patch
index 2a3a1e06ea370b4a75377583e3d4b2117ebb48c7..45a3f2700612dba999a96b28848669251e3218b7 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.23-rc6/scripts/genksyms/parse.c_shipped
-===================================================================
---- linux-2.6.23-rc6.orig/scripts/genksyms/parse.c_shipped     2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/scripts/genksyms/parse.c_shipped  2007-09-21 16:24:10.000000000 +0800
-@@ -144,7 +144,9 @@
+--- a/scripts/genksyms/parse.c_shipped
++++ b/scripts/genksyms/parse.c_shipped
+@@ -160,7 +160,9 @@
  
  
  #include <assert.h>
@@ -12,10 +10,8 @@ Index: linux-2.6.23-rc6/scripts/genksyms/parse.c_shipped
  #include "genksyms.h"
  
  static int is_typedef;
-Index: linux-2.6.23-rc6/scripts/genksyms/parse.y
-===================================================================
---- linux-2.6.23-rc6.orig/scripts/genksyms/parse.y     2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/scripts/genksyms/parse.y  2007-09-21 16:24:10.000000000 +0800
+--- a/scripts/genksyms/parse.y
++++ b/scripts/genksyms/parse.y
 @@ -24,7 +24,9 @@
  %{
  
@@ -26,10 +22,8 @@ Index: linux-2.6.23-rc6/scripts/genksyms/parse.y
  #include "genksyms.h"
  
  static int is_typedef;
-Index: linux-2.6.23-rc6/scripts/kallsyms.c
-===================================================================
---- linux-2.6.23-rc6.orig/scripts/kallsyms.c   2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/scripts/kallsyms.c        2007-09-21 16:24:10.000000000 +0800
+--- a/scripts/kallsyms.c
++++ b/scripts/kallsyms.c
 @@ -28,6 +28,35 @@
  #include <stdlib.h>
  #include <string.h>
@@ -66,11 +60,9 @@ Index: linux-2.6.23-rc6/scripts/kallsyms.c
  
  #define KSYM_NAME_LEN         128
  
-Index: linux-2.6.23-rc6/scripts/kconfig/Makefile
-===================================================================
---- linux-2.6.23-rc6.orig/scripts/kconfig/Makefile     2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/scripts/kconfig/Makefile  2007-09-21 16:24:10.000000000 +0800
-@@ -88,6 +88,9 @@
+--- a/scripts/kconfig/Makefile
++++ b/scripts/kconfig/Makefile
+@@ -93,6 +93,9 @@ check-lxdialog  := $(srctree)/$(src)/lxd
  # we really need to do so. (Do not call gcc as part of make mrproper)
  HOST_EXTRACFLAGS = $(shell $(CONFIG_SHELL) $(check-lxdialog) -ccflags)
  HOST_LOADLIBES   = $(shell $(CONFIG_SHELL) $(check-lxdialog) -ldflags $(HOSTCC))
@@ -80,10 +72,8 @@ Index: linux-2.6.23-rc6/scripts/kconfig/Makefile
  
  HOST_EXTRACFLAGS += -DLOCALE
  
-Index: linux-2.6.23-rc6/scripts/mod/mk_elfconfig.c
-===================================================================
---- linux-2.6.23-rc6.orig/scripts/mod/mk_elfconfig.c   2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/scripts/mod/mk_elfconfig.c        2007-09-21 16:24:10.000000000 +0800
+--- a/scripts/mod/mk_elfconfig.c
++++ b/scripts/mod/mk_elfconfig.c
 @@ -1,7 +1,11 @@
  #include <stdio.h>
  #include <stdlib.h>
@@ -96,10 +86,8 @@ Index: linux-2.6.23-rc6/scripts/mod/mk_elfconfig.c
  
  int
  main(int argc, char **argv)
-Index: linux-2.6.23-rc6/scripts/mod/modpost.h
-===================================================================
---- linux-2.6.23-rc6.orig/scripts/mod/modpost.h        2007-09-21 16:23:51.000000000 +0800
-+++ linux-2.6.23-rc6/scripts/mod/modpost.h     2007-09-21 16:24:10.000000000 +0800
+--- a/scripts/mod/modpost.h
++++ b/scripts/mod/modpost.h
 @@ -7,7 +7,11 @@
  #include <sys/mman.h>
  #include <fcntl.h>