update to 2.6.25.12
[openwrt/staging/dedeckeh.git] / target / linux / generic-2.6 / patches-2.6.25 / 921-gpio_spi_driver.patch
index 264386f330d8ae0505104e348632c9233228345d..4608a222d98619a0ab1ec7bfb4a5fd431efe67a3 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.25.10/include/linux/spi/spi_gpio.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.25.10/include/linux/spi/spi_gpio.h       2008-07-18 18:19:56.000000000 +0200
-@@ -0,0 +1,67 @@
+--- /dev/null
++++ b/include/linux/spi/spi_gpio.h
+@@ -0,0 +1,73 @@
 +/*
 + * spi_gpio interface to platform code
 + *
@@ -20,7 +18,9 @@ Index: linux-2.6.25.10/include/linux/spi/spi_gpio.h
 +#include <linux/spi/spi.h>
 +
 +
-+/** struct spi_gpio_platform_data - Data definitions for a SPI-GPIO device.
++/**
++ * struct spi_gpio_platform_data - Data definitions for a SPI-GPIO device.
++ *
 + * This structure holds information about a GPIO-based SPI device.
 + *
 + * @pin_clk: The GPIO pin number of the CLOCK pin.
@@ -56,13 +56,17 @@ Index: linux-2.6.25.10/include/linux/spi/spi_gpio.h
 +      void *boardinfo_setup_data;
 +};
 +
-+/** SPI_GPIO_PLATDEV_NAME - The platform device name string.
++/**
++ * SPI_GPIO_PLATDEV_NAME - The platform device name string.
++ *
 + * The name string that has to be used for platform_device_alloc
 + * when allocating a spi-gpio device.
 + */
 +#define SPI_GPIO_PLATDEV_NAME "spi-gpio"
 +
-+/** spi_gpio_next_id - Get another platform device ID number.
++/**
++ * spi_gpio_next_id - Get another platform device ID number.
++ *
 + * This returns the next platform device ID number that has to be used
 + * for platform_device_alloc. The ID is opaque and should not be used for
 + * anything else.
@@ -70,10 +74,8 @@ Index: linux-2.6.25.10/include/linux/spi/spi_gpio.h
 +int spi_gpio_next_id(void);
 +
 +#endif /* _LINUX_SPI_SPI_GPIO */
-Index: linux-2.6.25.10/drivers/spi/spi_gpio.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.25.10/drivers/spi/spi_gpio.c     2008-07-18 18:19:56.000000000 +0200
+--- /dev/null
++++ b/drivers/spi/spi_gpio.c
 @@ -0,0 +1,251 @@
 +/*
 + * Bitbanging SPI bus driver using GPIO API
@@ -326,11 +328,9 @@ Index: linux-2.6.25.10/drivers/spi/spi_gpio.c
 +MODULE_AUTHOR("Michael Buesch");
 +MODULE_DESCRIPTION("Platform independent GPIO bitbanging SPI driver");
 +MODULE_LICENSE("GPL v2");
-Index: linux-2.6.25.10/drivers/spi/Kconfig
-===================================================================
---- linux-2.6.25.10.orig/drivers/spi/Kconfig   2008-07-18 18:19:43.000000000 +0200
-+++ linux-2.6.25.10/drivers/spi/Kconfig        2008-07-18 18:19:56.000000000 +0200
-@@ -100,6 +100,19 @@ config SPI_BUTTERFLY
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -100,6 +100,19 @@
          inexpensive battery powered microcontroller evaluation board.
          This same cable can be used to flash new firmware.
  
@@ -341,7 +341,7 @@ Index: linux-2.6.25.10/drivers/spi/Kconfig
 +      help
 +        This is a platform driver that can be used for bitbanging
 +        an SPI bus over GPIO pins.
-+        Select this, if you have any SPI device that is connected via
++        Select this if you have any SPI device that is connected via
 +        GPIO pins.
 +        The module will be called spi_gpio.
 +
@@ -350,11 +350,9 @@ Index: linux-2.6.25.10/drivers/spi/Kconfig
  config SPI_IMX
        tristate "Freescale iMX SPI controller"
        depends on SPI_MASTER && ARCH_IMX && EXPERIMENTAL
-Index: linux-2.6.25.10/drivers/spi/Makefile
-===================================================================
---- linux-2.6.25.10.orig/drivers/spi/Makefile  2008-07-18 18:19:43.000000000 +0200
-+++ linux-2.6.25.10/drivers/spi/Makefile       2008-07-18 18:19:56.000000000 +0200
-@@ -16,6 +16,7 @@ obj-$(CONFIG_SPI_BFIN)                       += spi_bfin5xx.
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -16,6 +16,7 @@
  obj-$(CONFIG_SPI_BITBANG)             += spi_bitbang.o
  obj-$(CONFIG_SPI_AU1550)              += au1550_spi.o
  obj-$(CONFIG_SPI_BUTTERFLY)           += spi_butterfly.o
@@ -362,11 +360,9 @@ Index: linux-2.6.25.10/drivers/spi/Makefile
  obj-$(CONFIG_SPI_IMX)                 += spi_imx.o
  obj-$(CONFIG_SPI_LM70_LLP)            += spi_lm70llp.o
  obj-$(CONFIG_SPI_PXA2XX)              += pxa2xx_spi.o
-Index: linux-2.6.25.10/MAINTAINERS
-===================================================================
---- linux-2.6.25.10.orig/MAINTAINERS   2008-07-03 05:46:47.000000000 +0200
-+++ linux-2.6.25.10/MAINTAINERS        2008-07-18 18:20:28.000000000 +0200
-@@ -3685,6 +3685,11 @@ M:      dbrownell@users.sourceforge.net
+--- a/MAINTAINERS
++++ b/MAINTAINERS
+@@ -3685,6 +3685,11 @@
  L:    spi-devel-general@lists.sourceforge.net
  S:    Maintained