[adm5120] zyxel: use acx-mac80211 driver by default
[openwrt/svn-archive/archive.git] / target / linux / ifxmips / Makefile
index 3328960243f0bfdc47bfe4a3554c580b65200832..9de534358fc93e48ed53cac50a6a6aa4e38a9cf7 100644 (file)
@@ -9,13 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
-FEATURES:=squashfs jffs2
-SUBTARGETS:=generic nfs
-LINUX_VERSION:=2.6.26.8
-#LINUX_VERSION:=2.6.27.11
+FEATURES:=squashfs jffs2 atm
+SUBTARGETS:=danube ar9
+
+LINUX_VERSION:=2.6.35.9
+
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
+DEFAULT_PACKAGES+=uboot-lantiq kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control tapi_sip lqtapi_firmware_danube
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers