generic: yet another missing config symbol for 2.6.37
[openwrt/svn-archive/archive.git] / target / linux / ifxmips / Makefile
index 81bfd2e9bc90c43ab784c52fa3702f8dbac59546..9de534358fc93e48ed53cac50a6a6aa4e38a9cf7 100644 (file)
@@ -9,22 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
-FEATURES:=squashfs jffs2
+FEATURES:=squashfs jffs2 atm
+SUBTARGETS:=danube ar9
 
-LINUX_VERSION:=2.6.28.8
+LINUX_VERSION:=2.6.35.9
+
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
+DEFAULT_PACKAGES+=uboot-lantiq kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control tapi_sip lqtapi_firmware_danube
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers
 endef
 
-ifeq ($(KERNEL_PATCHVER),2.6.28)
-  define Kernel/Prepare
-       $(call Kernel/Prepare/Default)
-       mv $(LINUX_DIR)/include/asm-mips/* $(LINUX_DIR)/arch/mips/include/asm/
-  endef
-endif
-
 $(eval $(call BuildTarget))