build: add a config option for enabling a testing version of the target kernel
[openwrt/staging/jow.git] / target / linux / ipq40xx / Makefile
index 4813ad24254cfd23faff6cd00773bcd666e4e2e1..2785b73ed1583fa8cab13c1e072012c23b72392a 100644 (file)
@@ -10,14 +10,15 @@ MAINTAINER:=John Crispin <john@phrozen.org>
 
 # TODO: drop kmod-usb-dwc3-of-simple when migrating to 4.19
 KERNEL_PATCHVER:=4.14
+KERNEL_TESTING_PATCHVER := 4.19
 
 KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
+       kmod-usb-dwc3-of-simple \
        kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
        kmod-ath10k-ct wpad-basic \
-       kmod-usb3 kmod-usb-dwc3-of-simple kmod-usb-phy-qcom-dwc3 \
-       kmod-usb-dwc3-qcom ath10k-firmware-qca4019-ct
+       kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct
 
 $(eval $(call BuildTarget))