ipq40xx: convert AP-365 to DSA
[openwrt/staging/dedeckeh.git] / target / linux / ipq40xx / image / generic.mk
index a0ad63cfcecd3a588c5ad0546959a53090729ad5..2f0ca927f01aa20d9b75217416331b83c3a58677 100644 (file)
@@ -132,6 +132,7 @@ define Device/8dev_habanero-dvk
        IMAGE_SIZE := 30976k
        SOC := qcom-ipq4019
        IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | check-size | append-metadata
+       DEVICE_PACKAGES := ipq-wifi-8dev_habanero
 endef
 TARGET_DEVICES += 8dev_habanero-dvk
 
@@ -141,6 +142,7 @@ define Device/8dev_jalapeno-common
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        SOC := qcom-ipq4018
+       DEVICE_PACKAGES := ipq-wifi-8dev_jalapeno
 endef
 
 define Device/8dev_jalapeno
@@ -188,8 +190,7 @@ define Device/aruba_ap-365
        DEVICE_MODEL := AP-365
        DEVICE_PACKAGES := kmod-hwmon-ad7418 ipq-wifi-aruba_ap-365
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += aruba_ap-365
+TARGET_DEVICES += aruba_ap-365
 
 define Device/asus_map-ac2200
        $(call Device/FitImageLzma)
@@ -336,7 +337,7 @@ define Device/cilab_meshpoint-one
        $(call Device/8dev_jalapeno-common)
        DEVICE_VENDOR := Crisis Innovation Lab
        DEVICE_MODEL := MeshPoint.One
-       DEVICE_PACKAGES := kmod-i2c-gpio kmod-iio-bmp280-i2c kmod-hwmon-ina2xx kmod-rtc-pcf2127
+       DEVICE_PACKAGES += kmod-i2c-gpio kmod-iio-bmp280-i2c kmod-hwmon-ina2xx kmod-rtc-pcf2127
 endef
 # Missing DSA Setup
 #TARGET_DEVICES += cilab_meshpoint-one
@@ -1120,6 +1121,19 @@ endef
 # Missing DSA Setup
 #TARGET_DEVICES += unielec_u4019-32m
 
+define Device/wallys_dr40x9
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := Wallys
+       DEVICE_MODEL := DR40X9
+       SOC := qcom-ipq40x9
+       DEVICE_DTS_CONFIG := config@ap.dk07.1-c1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DEVICE_PACKAGES := ipq-wifi-wallys_dr40x9
+endef
+TARGET_DEVICES += wallys_dr40x9
+
 define Device/zte_mf18a
        $(call Device/FitImage)
        DEVICE_VENDOR := ZTE