ipq40xx: add support for MikroTik SXTsq 5 ac
[openwrt/staging/dedeckeh.git] / target / linux / ipq40xx / image / mikrotik.mk
index 9509ef8577391fb05c6785641caf7aaee09274b2..7c2fa52738f77ec39cf542a2f89010ea0dfccadf 100644 (file)
@@ -18,3 +18,11 @@ define Device/mikrotik_hap-ac2
                kmod-ath10k-ct-smallbuffers
 endef
 TARGET_DEVICES += mikrotik_hap-ac2
+
+define Device/mikrotik_sxtsq-5-ac
+       $(call Device/mikrotik_nor)
+       DEVICE_MODEL := SXTsq 5 ac (RBSXTsqG-5acD)
+       SOC := qcom-ipq4018
+       DEVICE_PACKAGES := ipq-wifi-mikrotik_sxtsq-5-ac rssileds
+endef
+TARGET_DEVICES += mikrotik_sxtsq-5-ac