kernel: bump 5.4 to 5.4.52
[openwrt/staging/hauke.git] / target / linux / ipq40xx / patches-5.4 / 705-net-add-qualcomm-ar40xx-phy.patch
index 6c823b3483400fbb8e332b8e5e604ab00f0e1297..17b1294fde1e10449e0ac6c713a52a5e31cbef96 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-5.4.51/drivers/net/phy/Kconfig
-===================================================================
---- linux-5.4.51.orig/drivers/net/phy/Kconfig
-+++ linux-5.4.51/drivers/net/phy/Kconfig
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
 @@ -587,6 +587,13 @@ config MDIO_IPQ40XX
          This driver supports the MDIO interface found in Qualcomm
          Atheros ipq40xx Soc chip.
@@ -16,10 +14,8 @@ Index: linux-5.4.51/drivers/net/phy/Kconfig
  endif # PHYLIB
  
  config MICREL_KS8995MA
-Index: linux-5.4.51/drivers/net/phy/Makefile
-===================================================================
---- linux-5.4.51.orig/drivers/net/phy/Makefile
-+++ linux-5.4.51/drivers/net/phy/Makefile
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
 @@ -70,6 +70,7 @@ ifdef CONFIG_HWMON
  aquantia-objs                 += aquantia_hwmon.o
  endif
@@ -28,10 +24,8 @@ Index: linux-5.4.51/drivers/net/phy/Makefile
  obj-$(CONFIG_AX88796B_PHY)    += ax88796b.o
  obj-$(CONFIG_AT803X_PHY)      += at803x.o
  obj-$(CONFIG_BCM63XX_PHY)     += bcm63xx.o
-Index: linux-5.4.51/drivers/net/phy/ar40xx.c
-===================================================================
 --- /dev/null
-+++ linux-5.4.51/drivers/net/phy/ar40xx.c
++++ b/drivers/net/phy/ar40xx.c
 @@ -0,0 +1,2118 @@
 +/*
 + * Copyright (c) 2016, The Linux Foundation. All rights reserved.
@@ -2151,10 +2145,8 @@ Index: linux-5.4.51/drivers/net/phy/ar40xx.c
 +
 +MODULE_DESCRIPTION("IPQ40XX ESS driver");
 +MODULE_LICENSE("Dual BSD/GPL");
-Index: linux-5.4.51/drivers/net/phy/ar40xx.h
-===================================================================
 --- /dev/null
-+++ linux-5.4.51/drivers/net/phy/ar40xx.h
++++ b/drivers/net/phy/ar40xx.h
 @@ -0,0 +1,342 @@
 +/*
 + * Copyright (c) 2016, The Linux Foundation. All rights reserved.