ipq806x: ArcherC2600: export usb power pins
[openwrt/staging/yousong.git] / target / linux / ipq806x / Makefile
index 97a40cfe0718db3a9e74d22ff2add1b97f40aaec..27ad6a4a0617bd6a5595e3ba947d415e98a226be 100644 (file)
@@ -5,19 +5,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs nand ubifs
-CPU_TYPE:=cortex-a9
+FEATURES:=squashfs nand ubifs fpu
+CPU_TYPE:=cortex-a15
 CPU_SUBTYPE:=neon-vfpv4
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=4.4
 
 KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
-       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform
-
+       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform \
+       kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
+       kmod-usb3 kmod-usb-dwc3-qcom kmod-usb-phy-qcom-dwc3 \
+       kmod-ath10k wpad-mini \
+       uboot-envtools
 
 $(eval $(call BuildTarget))